Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 459904 - kdelibs: kstandarddirs patch breaks use of KDEDIRS
Summary: kdelibs: kstandarddirs patch breaks use of KDEDIRS
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-24 08:53 UTC by Alwin
Modified: 2008-09-25 00:05 UTC (History)
5 users (show)

Fixed In Version: 4.1.0-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-25 00:05:03 UTC
Type: ---


Attachments (Terms of Use)

Description Alwin 2008-08-24 08:53:11 UTC
Description of problem:
You version of kdelibs makes impossible using the environment VARIABLE "KDEDIRS" which is strong required when developing KDE software using KParts. This happens 'cause your library ALWAYS first looks into the builtin kdedir eg. /usr/lib/kde4 for the part. So it is mostly impossible having prior versions installed and developing this software further.

Version-Release number of selected component (if applicable):
4.1.0-5 from testing

How reproducible:
take kdelibs from testing updates, checkout a developing project like kdesvn kde4-port branch, compile and install it, then try load another build of the part reached via KDEDIRS=<path-to-lib>:/usr environment. 

 
Actual results:
It always takes libs from /usr/lib/kde4 or /usr/lib64/kde4 first.


Expected results:
It should first look into pathes set with KDEDIRS then into standard path.

Additional info:
I fixed it building kdelibs package myself and NOT applying the patch "kdelibs-4.0.99-kstandarddirs.patch" (Patch 18 in spec file). So this patch should reviewed or removed, it seems useless. Removing the capability using KDEDIRS isn't a good idea for developers.

Comment 1 Rex Dieter 2008-08-24 11:17:11 UTC
There's good reason for the patch, but it's certainly a bug if it interferes with proper use of KDEDIRS.

Comment 2 Kevin Kofler 2008-08-27 08:22:54 UTC
There are even several good reasons for the patch, look at the package changelog for the Bugzilla IDs of kstandarddirs-related issues (which aren't showing up with the upstream default directory settings by mere luck) which it fixes.

I'll be fixing the patch ASAP, but just dropping it is not an option.

Also note that our 4.0.x packages behaved exactly the same way, this is not a new issue with 4.1.

Comment 3 Lukas Tvrdy 2008-08-27 08:32:34 UTC
I used kdelibs4 from updates-testing and it has problem.
I develop for KOffice/Krita using FC8 and when I installed KOffice 2.0
(in preffix ~/kde/inst ), i had big mess with KOffice 1 and KOffice 2 mixed up.
I install in that prefix, because I develop KOffice, it is in alpha state, so there is no reason to install it somewhere like /usr

So for now I'm forced to use self-compiled packages.

Comment 4 Kevin Kofler 2008-08-28 22:39:38 UTC
Should be fixed in 4.1.0-8 which I just committed to devel/rawhide. Builds coming soon.

Comment 5 Kevin Kofler 2008-08-29 09:43:21 UTC
Try kdelibs-4.1.0-9.fc9: http://koji.fedoraproject.org/koji/buildinfo?buildID=60797
(apidocs still building, the rest is built already).

Comment 6 Alwin 2008-09-12 08:57:47 UTC
With packages from updates-testing-newkey it works perfect so you may close it, Tnx!

Comment 7 Fedora Update System 2008-09-14 06:48:33 UTC
kdebase4-4.1.1-1.fc8, kdelibs4-4.1.1-5.fc8, kdepimlibs-4.1.1-2.fc8, kdebase-runtime-4.1.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase4 kdelibs4 kdepimlibs kdebase-runtime'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7838

Comment 8 Fedora Update System 2008-09-14 06:52:06 UTC
kdeaccessibility-4.1.1-1.fc9, kdeadmin-4.1.1-1.fc9, kdeartwork-4.1.1-1.fc9, kdebase-4.1.1-1.fc9, kdebase-runtime-4.1.1-2.fc9, kdebase-workspace-4.1.1-1.fc9, kdebindings-4.1.1-1.fc9, kdeedu-4.1.1-1.fc9, kdegames-4.1.1-1.fc9, kdegraphics-4.1.1-1.fc9, kdelibs-4.1.1-5.fc9, kdemultimedia-4.1.1-1.fc9, kdenetwork-4.1.1-1.fc9, kdeplasma-addons-4.1.1-1.fc9, kdesdk-4.1.1-1.fc9, kdetoys-4.1.1-1.fc9, kdeutils-4.1.1-1.fc9, guidance-power-manager-4.1.1-1.fc9, kiconedit-4.1.1-1.fc9, konq-plugins-4.1.1-1.fc9, kcoloredit-4.1.1-1.fc9, kdepimlibs-4.1.1-2.fc9, kde-l10n-4.1.1-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeaccessibility kdeadmin kdeartwork kdebase kdebase-runtime kdebase-workspace kdebindings kdeedu kdegames kdegraphics kdelibs kdemultimedia kdenetwork kdeplasma-addons kdesdk kdetoys kdeutils guidance-power-manager kiconedit konq-plugins kcoloredit kdepimlibs kde-l10n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7789

Comment 9 Fedora Update System 2008-09-25 00:00:59 UTC
kdepimlibs-4.1.1-2.fc8, kdebase-runtime-4.1.1-2.fc8, kdebase4-4.1.1-1.fc8, kdelibs4-4.1.1-12.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-09-25 00:04:54 UTC
kdeadmin-4.1.1-1.fc9, kdeartwork-4.1.1-1.fc9, kdebase-4.1.1-1.fc9, kdebase-runtime-4.1.1-2.fc9, kdebase-workspace-4.1.1-1.fc9, kdebindings-4.1.1-1.fc9, kdeedu-4.1.1-1.fc9, kdegames-4.1.1-1.fc9, kdegraphics-4.1.1-1.fc9, kdenetwork-4.1.1-1.fc9, kdeplasma-addons-4.1.1-1.fc9, kdesdk-4.1.1-1.fc9, kdetoys-4.1.1-1.fc9, kdeutils-4.1.1-1.fc9, guidance-power-manager-4.1.1-1.fc9, kiconedit-4.1.1-1.fc9, konq-plugins-4.1.1-1.fc9, kcoloredit-4.1.1-1.fc9, kdepimlibs-4.1.1-2.fc9, kdelibs-4.1.1-12.fc9, kde-l10n-4.1.1-2.fc9, kdemultimedia-4.1.1-2.fc9, kdeaccessibility-4.1.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.