Bug 459906 - gnome-power-man crashes with general protection when AC is unplugged
gnome-power-man crashes with general protection when AC is unplugged
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-24 05:15 EDT by Edouard Bourguignon
Modified: 2008-09-11 10:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 10:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my dmesg (53.59 KB, text/plain)
2008-08-24 05:15 EDT, Edouard Bourguignon
no flags Details

  None (edit)
Description Edouard Bourguignon 2008-08-24 05:15:49 EDT
Created attachment 314879 [details]
my dmesg

Description of problem:
Gnome-power-man applet disappear when removing AC. In dmesg the error is:
gnome-power-man[6470] general protection ip:4105c1 sp:7fff3726ec20 error:0 in gnome-power-manager[400000+4b000]

Version-Release number of selected component (if applicable):
gnome-power-manager-2.23.6-1.fc10.x86_64

How reproducible:
static

Steps to Reproduce:
1. Log in with AC plugged
2. Unplug AC
3. Move the mouse cursor over the g-p-m applet to see how much battery left. After a couple of seconds the applet crashs.
  
Actual results:
General protection fault, g-p-m applet is dead.

Expected results:
Shouldn't crash of course. Should show the time remaining on battery.

Additional info:
After that some other applets seems to crash:
gpk-update-icon[6439] general protection ip:3b21c104a8 sp:7fffd1850e18 error:0 in libpackagekit.so.4.0.0[3b21c00000+24000]
Comment 1 Richard Hughes 2008-09-10 08:42:13 EDT
I'm guessing the problem is now fixed in rawhide?
Comment 2 Edouard Bourguignon 2008-09-11 03:47:58 EDT
yes it's fixed in rawhide. You can close this bug. Thanks

Note You need to log in before you can comment on or make changes to this bug.