Bug 459911 - mdtool has wrong path to mdrun.exe on x86_64
mdtool has wrong path to mdrun.exe on x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-24 07:18 EDT by Ed Avis
Modified: 2008-11-29 09:39 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-29 09:39:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-08-24 07:18:43 EDT
% mdtool
Cannot open assembly /usr/lib/monodevelop/bin/mdrun.exe.
% uname -p
x86_64

This is because mdtool has

MD_BIN_PATH=/usr/lib/monodevelop/bin

but it should be /usr/lib64/monodevelop/bin.

I see the source package has a patch to change some paths, including this one, to use %libdir.  But it's the wrong libdir, on this platform.
Comment 1 Paul F. Johnson 2008-09-12 04:49:56 EDT
Should be fine when 1.0-6 hits paydirt (which should be sooner rather than later).
Comment 2 Ed Avis 2008-09-13 08:05:09 EDT
Version 1.0-6 of monodevelop?  Fedora 9 has monodevelop-0.19-6 and Fedora development has monodevelop-1.9-6, so I'm not sure what you mean.
Comment 3 Paul F. Johnson 2008-09-13 08:44:03 EDT
Waiting for gnome-desktop-sharp to get into F9, MD 1.0-6 will follow quickly
Comment 4 Ed Avis 2008-10-04 08:18:54 EDT
gnome-desktop-sharp hasn't yet appeared in Fedora 9 updates.  But do you expect monodevelop-1.0-6 will be included in Fedora 10?
Comment 5 Paul F. Johnson 2008-10-04 12:42:27 EDT
given f10 is the current rawhide and MD 1.9 is in there, then no ;-p. As soon as gnome-desktop-sharp is in F9, MD 1.0-7 will be built and it'll join the happy crew!

Note You need to log in before you can comment on or make changes to this bug.