Bug 459919 - Inconsistent text spacing in printouts
Inconsistent text spacing in printouts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-24 10:27 EDT by Brian Gerst
Modified: 2008-11-13 10:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 10:16:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example PDF printout (575.43 KB, application/pdf)
2008-08-24 10:27 EDT, Brian Gerst
no flags Details
minimal testcase, seems to be caused by font scale (319 bytes, text/html)
2008-10-30 10:49 EDT, Martin Stransky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 464684 None None None Never

  None (edit)
Description Brian Gerst 2008-08-24 10:27:32 EDT
Created attachment 314884 [details]
Example PDF printout

Description of problem:
Printing a page from Firefox 3 results in inconsistent text spacing.


Version-Release number of selected component (if applicable):
firefox-3.0.1-1.fc9.x86_64


How reproducible:
Consistent.


Steps to Reproduce:
1. Browse to http://fedoraproject.org
2. Print the page (to PDF or a physical printer)

  
Actual results:
Text spacing is wildly inconsistent making the page difficult to read.


Expected results:
Text spacing is consistent with rendered page on screen.


Additional info:
I reinstalled Firefox 2 from F8, and it prints out correctly.
Comment 1 Matěj Cepl 2008-08-25 12:19:25 EDT
Can very well reproduce with the same page and firefox-3.0.1-1.fc10.x86_64
and xulrunner-1.9.0.1-2.fc10.x86_64
Comment 2 Martin Stransky 2008-10-29 06:51:00 EDT
Taking this bug...
Comment 3 Martin Stransky 2008-10-30 10:49:50 EDT
Created attachment 321940 [details]
minimal testcase, seems to be caused by font scale
Comment 4 Matěj Cepl 2008-11-13 10:16:21 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=464684) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.