Bug 459939 - seahorse does not handle GnuPG keyring
seahorse does not handle GnuPG keyring
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-24 19:03 EDT by Michel Alexandre Salim
Modified: 2014-01-21 01:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 00:01:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-08-24 19:03:31 EDT
Description of problem:
Rawhide's seahorse does not handle my GnuPG keyring, and searching for GnuPG public keys does not work either. Also, the Help system does not work

Version-Release number of selected component (if applicable):
seahorse-2.23.6-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a GnuPG key
2. Start seahorse
  
Actual results:
No GnuPG key displayed

Expected results:
GnuPG keyring should be available

Additional info:
Comment 1 Michel Alexandre Salim 2008-08-24 20:57:48 EDT
Problem continues in latest version from Koji:
seahorse-2.23.90-1.fc10.x86_64
Comment 2 Michel Alexandre Salim 2008-08-30 22:55:11 EDT
Found the problem: we now BR on gnupg2, but because gnupg-1.4.x is still in the repository, the gnupg2 binary is called gnupg2, and thus seahorse's configure failed to detect it.

I'm building a fixed version right now:
http://koji.fedoraproject.org/koji/taskinfo?taskID=796122

Will commit the patch but refrain from pushing it for a few days for Seth's comment, but will push this in before the beta freeze at the latest unless I hear otherwise.
Comment 3 seth vidal 2008-08-30 23:19:23 EDT
If that's the problem, then commit it.

thanks,
Comment 4 Matthias Clasen 2008-10-25 00:01:26 EDT
* Sat Aug 30 2008 Michel Salim <salimma@fedoraproject.org> 2.23.90-2
- Patch configure to detect gpg2 binary

Note You need to log in before you can comment on or make changes to this bug.