Bug 459999 - Can't make second head come up (says "Video mode not supported")
Can't make second head come up (says "Video mode not supported")
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 11:25 EDT by Andrew Overholt
Modified: 2009-01-28 20:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 20:30:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of xrandr -q (787 bytes, text/plain)
2008-08-25 11:25 EDT, Andrew Overholt
no flags Details
/var/log/Xorg.0.log (3.70 MB, text/plain)
2008-08-25 11:26 EDT, Andrew Overholt
no flags Details
/etc/X11/xorg.conf (557 bytes, text/plain)
2008-08-25 11:28 EDT, Andrew Overholt
no flags Details
Xorg.0.log (104.52 KB, text/plain)
2008-09-05 15:00 EDT, Andrew Overholt
no flags Details
working dual head xorg.conf with radeonhd (1.00 KB, text/plain)
2008-09-05 15:02 EDT, Andrew Overholt
no flags Details
New xorg.conf (1.09 KB, text/plain)
2008-12-01 09:09 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Andrew Overholt 2008-08-25 11:25:39 EDT
Created attachment 314926 [details]
Output of xrandr -q

Description of problem:
I purchased an "ASUS EAH3650 SILENT MAGIC/HTDP/512M ATI Radeon HD 3650 Chipset (725MHz ) 512MB (1000Mhz) DDR2 Dual DVI Display PCI-Express 2.0 Graphics Card" [1] which has two DVI outputs.  I can get both of my monitors to display X correctly when they're on one of the outputs but not the other.

Version-Release number of selected component (if applicable):
F-8 latest X stack

How reproducible:
Always

I'll attach the output of xrandr -q, my Xorg.0.log, and the xorg.conf I tried.

Additional info:
I'm going to try upgrading to F-9 because I don't know how to set the Virtual screen size when booted from a live CD.

[1]
http://canadacomputers.com/index.php?do=ShowProduct&cmd=pd&pid=018778&cid=999.243.272
Comment 1 Andrew Overholt 2008-08-25 11:26:50 EDT
Created attachment 314927 [details]
/var/log/Xorg.0.log

I should have noticed that the version was in the log file.  I'm running 1.3.0.0-47.fc8
Comment 2 Andrew Overholt 2008-08-25 11:28:27 EDT
Created attachment 314928 [details]
/etc/X11/xorg.conf

This is the xorg.conf I tried (just one head) and tried to add a second head with commands like:

xrandr --output HDMI-0 --right-of DVI-0

It appeared that the output was created but the monitor just began showing "Video mode not supported".
Comment 3 Andrew Overholt 2008-08-25 11:28:59 EDT
FWIW I have two Samsung SyncMasters, one 191T+ and one 910T.  They're both 19" 1280x1024-capable LCDs.
Comment 4 Andrew Overholt 2008-08-27 08:40:09 EDT
I upgraded to Fedora 9 last night and this still happens.  I tried xrandr --output HDMI-0 --right-of DVI-0 and got nothing on my second monitor.  I tried turning it off and on, forcing a sync, etc. but it couldn't/wouldn't display what the second DVI output was putting out.  X seemed happy and I was able to move my mouse over to the right where it thought there was something I could see.
Comment 5 Matěj Cepl 2008-09-05 11:53:45 EDT
Andrew, when you just move /etc/X11/xorg.conf away and restart Xorg, what
happens? Can we get /var/log/Xorg.0.log from that as well, please?
Comment 6 Andrew Overholt 2008-09-05 15:00:09 EDT
Created attachment 315927 [details]
Xorg.0.log

When I move /etc/X11/xorg.conf out of the way and log out/log in, I get only one head.  xrandr --output HDMI-0 --right-of DVI-0 says "screen cannot be larger than 1400x1400 (desired size 2560x1024)".

/var/log/Xorg.0.log from running with no xorg.conf attached.

Note:  I've since got this working by using radeonhd.
Comment 7 Andrew Overholt 2008-09-05 15:02:59 EDT
Created attachment 315928 [details]
working dual head xorg.conf with radeonhd
Comment 8 Jóhann B. Guðmundsson 2008-12-01 06:33:06 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 9 Andrew Overholt 2008-12-01 08:29:26 EST
I've solved this by using radeonhd.  Do you want me to try it with radeon?
Comment 10 Jóhann B. Guðmundsson 2008-12-01 09:09:01 EST
Yup please do. 

Have you updated to cambridge? 

Could you try it with radeon and then again without an xorg.conf

Then see of you can configure it with gnome-display-properties that is 
if you use Gnome.

Hum also noticed that your xorg.conf differes a bit from what I would
have created 

So I created one suited to your setup as I would have set it up... 

You can replace mine with yours ( just remember to back yours up first )
and try it and then see if you cant use gnome-display-properties to 
configure...
Comment 11 Jóhann B. Guðmundsson 2008-12-01 09:09:48 EST
Created attachment 325235 [details]
New xorg.conf
Comment 12 Andrew Overholt 2008-12-01 09:19:50 EST
I have yet to update to F10.  I'll try this when I do.  Thanks.
Comment 13 Jóhann B. Guðmundsson 2008-12-01 09:26:47 EST
Could you try this with your current release.

In F10 you definitely should not need any xorg.conf unless you 
are going to use the radeonhd driver.
Comment 14 Matěj Cepl 2009-01-27 21:06:16 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 15 Andrew Overholt 2009-01-28 11:07:25 EST
I'm only able to try this with Fedora 9.  I'll try to get to it tonight.
Comment 16 Jóhann B. Guðmundsson 2009-01-28 11:14:21 EST
You could try it with an live iso of F10 that wont affect your current installation.
Comment 17 Andrew Overholt 2009-01-28 20:30:20 EST
I'm sorry for the delay.

I *just* tried a live F10 image and with no xorg.conf (I'm booting from a CD) I can run:

xrandr --output HDMI-0 --right-of DVI-0

and I get two separate heads!  Thanks!

For reference, this live image has xorg-x11-drv-ati-6.9.0-54.fc10.i386

Note You need to log in before you can comment on or make changes to this bug.