Bug 460013 - Modify gnome-python2 requirement
Summary: Modify gnome-python2 requirement
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 456122
TreeView+ depends on / blocked
 
Reported: 2008-08-25 15:56 UTC by Matthew Barnes
Modified: 2008-09-01 15:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-01 15:32:59 UTC
Type: ---


Attachments (Terms of Use)

Description Matthew Barnes 2008-08-25 15:56:05 UTC
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.

Comment 1 Bastien Nocera 2008-09-01 15:32:59 UTC
Doesn't look like we need the -gnome subpackage for rhythmbox, thanks for the heads up.


Note You need to log in before you can comment on or make changes to this bug.