Bug 460016 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-cluster (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-08-25 11:56 EDT by Matthew Barnes
Modified: 2009-11-06 07:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 07:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:56:20 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Jan "Yenya" Kasprzak 2009-06-23 12:22:13 EDT
This bug is still present in F11.
Comment 2 Steve Whitehouse 2009-11-06 07:01:12 EST
The system-config-cluster package has been retired in fedora rawhide, so the bugs assigned to it are being closed at WONTFIX since there is no upstream for this project any more.

If this bug has been closed in error, please reopen it against a different package or version.

Note You need to log in before you can comment on or make changes to this bug.