Bug 460018 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 456122
  Show dependency treegraph
Reported: 2008-08-25 11:56 EDT by Matthew Barnes
Modified: 2009-08-11 20:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-11 20:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:56:31 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Itamar Reis Peixoto 2009-08-11 13:56:30 EDT
moving bug to gnome-python2 package.
Comment 2 Matthew Barnes 2009-08-11 20:40:07 EDT
Reassigning this bug to gnome-python2 is incorrect.
I'll assume this is not an issue for system-config-lvm.

Note You need to log in before you can comment on or make changes to this bug.