Bug 460027 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: decibel-audio-player (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-08-25 11:58 EDT by Matthew Barnes
Modified: 2008-12-14 12:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 12:30:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:58:22 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Debarshi Ray 2008-11-07 13:30:12 EST
Browsing through the sources I could not locate something equivalent to 'import gnome' or 'import gnome.ui'. So my guess is that this package is not affected by the split.
Comment 2 Debarshi Ray 2008-11-15 08:24:24 EST
I was wrong. This is fixed in decibel-audio-player-0.11-1.
Comment 3 Fedora Update System 2008-11-19 09:54:02 EST
decibel-audio-player-0.11-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update decibel-audio-player'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9766
Comment 4 Fedora Update System 2008-11-22 11:54:34 EST
decibel-audio-player-0.11-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update decibel-audio-player'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10000
Comment 5 Fedora Update System 2008-12-02 20:18:04 EST
decibel-audio-player-0.11-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-12-02 20:30:54 EST
decibel-audio-player-0.11-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.