Bug 460031 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: audit-viewer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-08-25 11:58 EDT by Matthew Barnes
Modified: 2008-08-26 16:05 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 16:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:58:41 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Miloslav Trmač 2008-08-26 16:05:21 EDT
Updated in audit-viewer-0.3-2.  Thanks for the notice.

Note You need to log in before you can comment on or make changes to this bug.