Bug 460074 - unacceptable data loss (unconvertability) on upgrading
unacceptable data loss (unconvertability) on upgrading
Status: CLOSED DUPLICATE of bug 398221
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 21:54 EDT by Frank Ch. Eigler
Modified: 2013-07-02 23:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 22:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2008-08-25 21:54:58 EDT
Upon a recent update to fedora 9 that included a bump to postgresql 
(8.3.3-2.fc9), I was shocked to find that the data migration widgets
formerly in the rpm spec file have been disabled.  Now my data is dead
and inaccessible unless I somehow reinstall the previous version of
postgresql by hand, dump the data, update postgresql again, and then
restore.

This is unacceptable.

Some possible fixes:
- the automagic rpm data migration script should be brought back
- postgresql should be fixed to migrate its own old data files
- postgresql rpm should forbid updating itself -- probably
  also possible with a simple rpm spec hack %pre_inst
Comment 1 Tom Lane 2008-08-25 22:51:48 EDT
AFAIK there have never been any "data migration widgets" in any postgres RPM shipped by Red Hat.  I know some other distros have tried to handle that automagically, but it generally doesn't work very well --- running arbitrary code in a scriptlet is a bad idea.

Upstream is aware that upgrade-in-place would be a nice thing to have, but it's a hard problem...

*** This bug has been marked as a duplicate of bug 398221 ***

Note You need to log in before you can comment on or make changes to this bug.