Bug 460076 - Evolution crashes when accessing the mail component
Evolution crashes when accessing the mail component
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 22:08 EDT by Kyle Gonzales
Modified: 2008-08-25 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 22:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Gonzales 2008-08-25 22:08:28 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072301 Fedora/3.0.1-1.fc10 Firefox/3.0.1

Using Fedora 10 Alpha, and upgraded Evolution to the following:

$ rpm -q evolution evolution-data-server
evolution-2.23.6-1.fc10.i386
evolution-data-server-2.23.6-3.fc10.i386

When evolution is started with the mail component as default, or when starting under another component and switching to the mail component, evolution crashed.  When run from the command line, you see this error:

evolution: symbol lookup error: /usr/lib/evolution/2.24/components/libevolution-mail.so: undefined symbol: gtk_html_set_caret_first_focus_anchor


Reproducible: Always

Steps to Reproduce:
1. Open Evolution with mail as default, or switch to mail component.
Actual Results:  
Evolution crashed.

Expected Results:  
Evolution does not crash.

The Evolution that came on the F10 Alpha CD worked fine, but did not include the Google Contacts functionality that was in this version.
Comment 1 Matthew Barnes 2008-08-25 22:46:02 EDT
I think you just need to update your gtkhtml3 package.  Looks like a recently added symbol to gtkhtml3, and sometimes these things slip through and minimum version requirements don't get properly updated.
Comment 2 Matthew Barnes 2008-08-25 22:59:17 EDT
Version requirements corrected in evolution-2.23.90-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.