Bug 460080 - fstyp's hardcoded into mkdumprd
fstyp's hardcoded into mkdumprd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
9
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 23:27 EDT by Richard P
Modified: 2008-08-26 06:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 06:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard P 2008-08-25 23:27:47 EDT
Description of problem:

kdump kernel fails to boot if root fstyp not ext2, ext3 or minix.
Root cause is mkdumprd; it hardcodes ext2, ext3 & minix into the 
generated initrd.

Version-Release number of selected component (if applicable):

Fedora 9 - kexec-tools-1.102pre-8.fc9.x86_64

How reproducible:

I my case, fstyp of root file system was reiserfs.

Steps to Reproduce
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Perhaps the mkdumprd script could be enhanced to extract fstyp from fstab ?
Comment 1 Neil Horman 2008-08-26 06:45:44 EDT
kdump only supports root filesystems that are ext2/3 or minix.  If you have a root filesystem that is not one of those types, then you need to select an alternate dump target (see kdump.conf)

Note You need to log in before you can comment on or make changes to this bug.