Bug 460084 - java plugin not working in firefox
java plugin not working in firefox
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 00:17 EDT by Ian Mortimer
Modified: 2008-10-22 17:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 09:50:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2008-08-26 00:17:45 EDT
Description of problem:
On fresh installs of Fedora 9, the openjdk java plugin doesn't run the java test applets at http://www.javatester.org/ and other test sites linked from there.  Other sites using java don't work either.

Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-plugin-1.6.0.0-0.16.b09.fc9
firefox-3.0.1-1.fc9


How reproducible:
Always.  Tried on a number of hosts with fresh installs of F9 x86_64 and i386.

Steps to Reproduce:
1. start firefox
2. go to (for example): http://www.upshot.com/login/javatest/logo/javavmtest.html
3.
  
Actual results:
Blank window where java applet should display.  No java version reported.

Expected results:
A spinning triangle should appear, the jvm version should be displayed.


Additional info:

about:plugins reports: GCJ Web Browser Plugin (using IcedTea) 1.2
 
on the i386 hosts, sun's jre-1.6.0_07 works.  Unfortunately not on the x86_64 hosts (with nspluginwrapper).
Comment 1 Lillian Angel 2008-08-26 09:50:15 EDT
Works perfectly fine for me. It  may be possible the links are not set up properly since you have sun's plugin installed as well.
Comment 2 Ian Mortimer 2008-08-26 18:13:23 EDT
> It  may be possible the links are not set up
> properly since you have sun's plugin installed as well.

Most of these hosts have never had sun java installed.  I installed it on a couple for testing only after the openjdk plugin failed to work.

After some more testing my conclusion is it's not working here because we go through a squid proxy.  With the proxy bypassed, all the test java applets work.  Through the proxy none of them work.

Because you've closed this bug, I'll open another bug with the additional information.


Thanks
--
Ian
Comment 3 Lillian Angel 2008-10-22 17:31:01 EDT
will be in rawhide in the next couple of days.

java-1.6.0-openjdk-1.6.0.0-1.0.b12.fc10

Note You need to log in before you can comment on or make changes to this bug.