Bug 460096 - .spec lacks buildrequires [NEEDINFO]
.spec lacks buildrequires
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pwlib (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 02:48 EDT by Zenon Panoussis
Modified: 2014-06-02 09:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (redhatbugs)


Attachments (Terms of Use)
Fix (1.38 KB, patch)
2008-08-26 03:17 EDT, Zenon Panoussis
no flags Details | Diff

  None (edit)
Description Zenon Panoussis 2008-08-26 02:48:52 EDT
Description of problem:

Attempting to build pwlib.src.rpm crashes with 
checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details

config.log complains that limits.h cannot be found. 

gcc provides limits.h in /usr/lib/gcc/i386-redhat-linux/4.1.1/include, where pwlib's configure can't find it. glibc-headers provides limits.h in /usr/include, where the configure script does find it.


Version-Release number of selected component (if applicable):

pwlib-1.10.1-7.0.1.el5


Solution:

Either add "buildrequires: glibc-headers" to pwlib.spec or else patch its configure script to look for header files in /usr/lib/gcc/i386-redhat-linux/<version>/include.


Other

Why does the .spec say "--disable-oss"? This is why I have to rebuild it and there is no explanation in the changelog. Could OSS perhaps be enabled in the distro package?
Comment 1 Zenon Panoussis 2008-08-26 03:14:52 EDT
Some additional notes:

In an out-of-the-box installation, ekiga is locked to ALSA and has no sound. OSS cannot be enabled because pwlib is built --without-oss. This is a coordination fault in the distro. 

Enabling OSS in pwlib doesn't seem to break anything (at first glance) and allows ekiga to work while leaving the system in its default sound system configuration. Thus, there appears to be no reason for disabling OSS in pwlib.
Comment 2 Zenon Panoussis 2008-08-26 03:17:03 EDT
Created attachment 314966 [details]
Fix
Comment 3 Daniel Veillard 2008-08-27 05:19:26 EDT
Sounds reasonable, though I wonder how to reproduce testing, people certainly
had sound enable with just ALSA, just that for some reason ALSA didn't gave
you any sound. Can you elaborate ?

Daniel
Comment 4 RHEL Product and Program Management 2008-08-27 05:22:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Zenon Panoussis 2008-08-28 11:09:39 EDT
I have actually filed two different issues as one single bug, which isn't very good. The building problem (limits.h) is one issue, enabling OSS is another. Perhaps they should be split into two separate bugs, also because the dependency problem is a bug that can and should be fixed now, while enabling OSS is more like a feature request which can wait for a future release. 


In reply to comment #3:
I'm not sure why OSS is used by default instead of ALSA on my machine; perhaps because of the sound card on this specific box (a Fujitsu-Siemens Esprimo V5505). You should be able to reproduce the situation on any machine though by just disabling ALSA and then trying to run ekiga.
Comment 6 RHEL Product and Program Management 2014-03-07 08:46:30 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:21:03 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.