Bug 460118 - glibc configure complains about "old 'crypt' add-on"
glibc configure complains about "old 'crypt' add-on"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 05:11 EDT by Denys Vlasenko
Modified: 2008-09-04 11:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 19:01:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exclude crypt and localedata from the list of automatically selected addons (531 bytes, patch)
2008-08-26 05:12 EDT, Denys Vlasenko
no flags Details | Diff

  None (edit)
Description Denys Vlasenko 2008-08-26 05:11:38 EDT
Trying to configure glibc with just

$src/configure --prefix=/usr

doesn't work, it says:

*** It seems that you're using an old `crypt' add-on.  crypt is now
*** part of glibc and using the old add-on will not work with this
*** release.  Start again with fresh sources and without the old

But the user did NOT specify "crypt" addon, configure picked it up
automatically! This is stupid.

Looks like it was introduced quite some time ago:

http://www.cygwin.com/ml/libc-hacker/2001-01/msg00040.html

The fix is trivial, attaching it.
Comment 1 Denys Vlasenko 2008-08-26 05:12:41 EDT
Created attachment 314968 [details]
Exclude crypt and localedata from the list of automatically selected addons
Comment 2 Ulrich Drepper 2008-09-03 19:01:31 EDT
No, we are not adding work-arounds for user errors.  Just remove those directories.
Comment 3 Denys Vlasenko 2008-09-04 05:32:04 EDT
But those directories come directly from glibc cvs tree, I did not create them. What I am doing wrong?
Comment 4 Ulrich Drepper 2008-09-04 11:57:21 EDT
Remove them or do it as everybody does, use --enable-add-ons=libidn,nptl.

Note You need to log in before you can comment on or make changes to this bug.