Bug 460123 - rpm-devel installs broken link: /usr/bin/moc-qt4 -> ../../../bin/moc-qt4
rpm-devel installs broken link: /usr/bin/moc-qt4 -> ../../../bin/moc-qt4
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 06:52 EDT by John Ellson
Modified: 2008-08-26 15:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 07:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-08-26 06:52:32 EDT
Description of problem:
A fresh install of qt-devel.x86_64 rpm results in a broken softlink:
lrwxrwxrwx 1 root root 20 2008-08-26 06:44 /usr/bin/moc-qt4 -> ../../../bin/moc-qt4


Version-Release number of selected component (if applicable):
qt-devel-4.4.1-2.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. rpm -e qt-devel 
2. yum install qt-devel
3.
  
Actual results:
lrwxrwxrwx 1 root root 20 2008-08-26 06:44 /usr/bin/moc-qt4 -> ../../../bin/moc-qt4

Expected results:
a working moc facility

Additional info:
Comment 1 Kevin Kofler 2008-08-26 07:02:05 EDT
That's what happens when you previously used a broken qt build which never went anywhere except Rawhide, which has /usr/lib64/qt4/bin symlinked to /usr/bin. The reason it didn't get beyond Rawhide is that it upgrades from previous builds to that build failed because RPM can't replace a directory with a symlink. But you were one of the unlucky few who first installed qt exactly at that time, so the install worked for you, and then the upgrade to the fixed version didn't because RPM also chokes on replacing a symlink with a directory.

What you did is also not a completely fresh install, you didn't rpm -e qt.

To fix your issue, try:
rm -f /usr/lib64/qt4/bin
rpm -e --nodeps qt qt-devel
yum install qt qt-devel

Other qt-* subpackages may also need reinstalling.
Comment 2 Kevin Kofler 2008-08-26 07:03:08 EDT
Marking this CANTFIX because it's a bug in an old build which we can't retroactively fix. I'm afraid this kind of situations are part of the Rawhide experience.
Comment 3 John Ellson 2008-08-26 15:59:44 EDT
Understood.  Thanks for helping me fix the mess.  Seems OK now.

Note You need to log in before you can comment on or make changes to this bug.