This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 460141 - gtk-doc generates different IDs on subsequent runs
gtk-doc generates different IDs on subsequent runs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-doc (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Colin Walters
desktop-bugs@redhat.com
:
: 460142 (view as bug list)
Depends On: 660682
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 09:41 EDT by Bastien Nocera
Modified: 2016-09-21 12:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 660682 (view as bug list)
Environment:
Last Closed: 2014-06-02 09:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-08-26 09:41:52 EDT
gtk-doc generates different section IDs on separate runs, which can cause multilib problems, as can be seen in rpmdiff runs:
---8<--
Multilib regressions for usr/share/gtk-doc/html/gst-plugins-base-libs-0.10/api-index.html on i386 vs x86_64:

--- /tmp/rpmdf/inputs/after/i386/gstreamer-plugins-base-devel/payload/usr/share/gtk-doc/html/gst-plugins-base-libs-0.10/api-index.html	2008-08-08 10:08:15.000000000 -0400
+++ /tmp/rpmdf/inputs/after/x86_64/gstreamer-plugins-base-devel/payload/usr/share/gtk-doc/html/gst-plugins-base-libs-0.10/api-index.html	2008-08-08 10:08:08.000000000 -0400
@@ -40,1775 +40,1775 @@
 <div class="index"><div class="indexdiv">
 <h3>G</h3>
 <dl>
-<dt>GDOUBLE_FROM_BE, <a href="gst-plugins-base-libs-gstfloatcast.html#id2545354">GDOUBLE_FROM_BE()</a>
+<dt>GDOUBLE_FROM_BE, <a href="gst-plugins-base-libs-gstfloatcast.html#id320210">GDOUBLE_FROM_BE()</a>
 </dt>
---8<--
Comment 2 Bastien Nocera 2008-08-26 09:48:33 EDT
*** Bug 460142 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2009-03-26 13:19:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Alexander Todorov 2010-12-07 10:28:57 EST
Hi Matthias,
are there any plans to fix this in EL5? QE is seeing similar issues on EL6 and the question is to clone or move this one to RHEL6?

In the mean time I'm proposing it for 5.6 fast.
Comment 5 Kamil Dudka 2010-12-07 10:43:04 EST
A viable start would be to fix the issue in Fedora IMO.
Comment 6 Matthias Clasen 2010-12-07 11:39:41 EST
The ids are generated by libxslt.
Fixing this in gtk-doc will be very difficult.
Comment 7 Kamil Dudka 2010-12-07 11:51:35 EST
Do they need to be generated even if they are not anyhow used later on?

Preventing gtk-doc from generating unused IDs would solve the problem for unicap.
Comment 13 RHEL Product and Program Management 2013-07-24 00:20:20 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2014-03-07 08:56:17 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 15 RHEL Product and Program Management 2014-06-02 09:23:30 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.