Bug 460160 - ise, after package search
ise, after package search
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Red Hat Satellite QA List
https://rlx-3-18.rhndev.redhat.com/rh...
:
Depends On:
Blocks: space02
  Show dependency treegraph
 
Reported: 2008-08-26 11:29 EDT by wes hayutin
Modified: 2009-09-17 03:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2008-08-26 11:29:24 EDT
Description of problem:

channels, package search
search for "bash"

[root@rlx-3-18 ~]$ cat /dev/null > /var/log/tomcat5/catalina.out

[root@rlx-3-18 ~]$ cat /var/log/tomcat5/catalina.out

2008-08-26 11:17:08,045 [TP-Processor19] WARN  com.redhat.rhn.frontend.action.channel.PackageSearchAction - Performing pkg search

2008-08-26 11:17:09,184 [TP-Processor19] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.NullPointerException

2008-08-26 11:17:09,186 [TP-Processor19] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back

javax.servlet.ServletException

        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)

        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)

        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)

        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)

        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)

        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)

        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)

        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)

        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)

        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)

        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)

        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)

        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)

        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)

        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)

        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)

        at java.lang.Thread.run(Thread.java:636)

Caused by: java.lang.NullPointerException

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.performSearch(PackageSearchAction.java:273)

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.setupForm(PackageSearchAction.java:200)

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.execute(PackageSearchAction.java:89)

        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)

        ... 40 more

2008-08-26 11:17:09,196 [RHN Message Dispatcher] WARN  com.redhat.rhn.common.messaging.SmtpMail - MessagingException while trying to send email: javax.mail.NoSuchProviderException: smtp

2008-08-26 11:17:09,197 [RHN Message Dispatcher] ERROR com.redhat.rhn.common.messaging.ActionExecutor - com.redhat.rhn.common.messaging.JavaMailException: MessagingException while trying to send email: javax.mail.NoSuchProviderException: smtp

2008-08-26 11:17:09,199 [TP-Processor19] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn].[action] - Servlet.service() for servlet action threw exception

java.lang.NullPointerException

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.performSearch(PackageSearchAction.java:273)

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.setupForm(PackageSearchAction.java:200)

        at com.redhat.rhn.frontend.action.channel.PackageSearchAction.execute(PackageSearchAction.java:89)

        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)

        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)

        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)

        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)

        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)

        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)

        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)

        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)

        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)

        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)

        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)

        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)

        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)

        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)

        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)

        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)

        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)

        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)

        at java.lang.Thread.run(Thread.java:636)

[root@rlx-3-18 ~]$
Comment 1 Devan Goodwin 2008-09-05 11:22:36 EDT
I think this was fixed somewhere along the way. Package search as described seems ok in spacewalk 0.2.
Comment 2 Miroslav Suchý 2009-09-17 03:00:13 EDT
Spacewalk is released for long time.

Note You need to log in before you can comment on or make changes to this bug.