Bug 460168 - FedoraDS' adminutil requires non-existent "icu.pc" on non-RH/Fedora OS
FedoraDS' adminutil requires non-existent "icu.pc" on non-RH/Fedora OS
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.1.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
: VerifiedUpstream
Depends On:
Blocks: 389_1.2.6
  Show dependency treegraph
 
Reported: 2008-08-26 11:57 EDT by bwailea+11
Modified: 2015-12-07 11:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:50:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (1.11 KB, patch)
2010-02-26 14:21 EST, Rich Megginson
nkinder: review+
Details | Diff

  None (edit)
Description bwailea+11 2008-08-26 11:57:54 EDT
FedoraDS "Building" docs @,

	http://directory.fedoraproject.org/wiki/Building#External_Requirements

state,

	" ... The directory server configure script will first attempt to find these components using pkg-config (e.g. pkg-config --libs nspr) or the package specific config script (e.g. icu-config or net-snmp-config) ..."

Build/install of 'adminutil' however installs creates "adminutil.pc",

	cat /usr/lib/pkgconfig/adminutil.pc
		prefix=/usr
		exec_prefix=/usr
		libdir=${exec_prefix}/lib
		includedir=${prefix}/include
		
		Name: adminutil
		Description: Utility library for directory server administration
		Version: 1.1.6
		Requires: nspr, nss, svrcore, mozldap, icu
		Libs: -ladmsslutil -ladminutil
		Cflags: -I${includedir}/admsslutil -I${includedir}/adminutil

which instructs pkg-config to "require", and fails for lack of, icu.pc,

	pkg-config --libs adminutil
		Package adminutil was not found in the pkg-config search path.
		Perhaps you should add the directory containing `adminutil.pc'
		to the PKG_CONFIG_PATH environment variable
		No package 'adminutil' found
		containing a "Require" for icu -- 

installation of ICU from raw source creates/installs *no* icu.pc, rather icu-config.

rpm-install of icu on OpenSuse does the same -- no icu.pc.

afaict, only redhat/fedora seem to install/require the "non-standard" icu.pc, despite the docs.

modding adminutil.pc,

	-	Requires: nspr, nss, svrcore, mozldap, icu
	+	Requires: nspr, nss, svrcore, mozldap

removes the 'fail'.  as for downstream,

richm @ #fedora-ds
	"the only packages that use adminutil are fedora-ds-admin and fedora-ds-dsgw - and both of those require icu separately, so removing that Requires should cause no problems."

nonetheless, DS sources should depend on standard/documented icu-config, rather than on mfg'd icu.pc.
Comment 1 Rich Megginson 2010-02-26 14:21:34 EST
Created attachment 396645 [details]
patch
Comment 2 Rich Megginson 2010-02-26 18:10:59 EST
commit 2720ccb5a5637ec9224ef180437f68505d07135a
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Fri Feb 26 12:19:15 2010 -0700

    Reviewed by: nkinder (Thanks!)
    Branch: HEAD
Comment 3 Fedora Update System 2010-02-26 21:04:25 EST
389-adminutil-1.1.10-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/389-adminutil-1.1.10-1.fc12
Comment 4 Fedora Update System 2010-02-26 21:04:30 EST
389-adminutil-1.1.10-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/389-adminutil-1.1.10-1.fc13
Comment 5 Fedora Update System 2010-02-26 21:04:34 EST
389-adminutil-1.1.10-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/389-adminutil-1.1.10-1.fc11
Comment 8 Steven R. Loomis 2012-08-15 19:38:32 EDT
(In reply to comment #0)
> installation of ICU from raw source creates/installs *no* icu.pc, rather
> icu-config.

That's because the downstream (RedHat) went ahead and created icu.pc without contributing the patch back up. 

When I implemented http://bugs.icu-project.org/trac/ticket/6981 we created separate .pc's, because there are multiple patches.

I filed a ticket in ICU, http://bugs.icu-project.org/trac/ticket/9478 to create a deprecated icu.pc for compatibility.

Note You need to log in before you can comment on or make changes to this bug.