Bug 460199 - Add/Remove Software cannot continue if a selected package is already installed
Add/Remove Software cannot continue if a selected package is already installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On: 459870
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 15:19 EDT by Janne Enberg
Modified: 2008-10-27 09:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janne Enberg 2008-08-26 15:19:08 EDT
Description of problem:
If you manage to choose packages that area already installed in the "Add/Remove Software" -lists, after you press apply you get an error saying "The package is already installed" and are given only the option to "Close" the dialog.

Closing the dialog will end the installation process without installing ANY other packages you might've chosen in addition to the already installed one(s).

The only way I know of to choose packages that are already installed is after bumping into the bug of installed packages shown as not installed when you select "Only available" in the filter, but this should still be fixed in case of other ways, future or present, to select already installed packages.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open "Add/Remove Software", choose "Only available" in the Filter->Installed menu.
2. Choose a couple of packages you want to install and some packages you know are installed already.
3. Click Apply.
  
Actual results:
Nothing is installed.

Expected results:
The packages not already installed are installed and a notification is given of the already installed packages.

Additional info:
Comment 1 Robin Norwood 2008-08-28 13:15:02 EDT
This should also be fixed by the fix to bug #459870
Comment 2 Richard Hughes 2008-10-27 09:21:03 EDT
Yup, works for me. Thanks.

Note You need to log in before you can comment on or make changes to this bug.