Bug 460226 - Enabling Config Mang via webui fails
Enabling Config Mang via webui fails
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://rlx-3-18.rhndev.redhat.com/rh...
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-08-26 16:54 EDT by wes hayutin
Modified: 2008-10-13 13:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 13:12:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalina.out (23.10 KB, text/plain)
2008-08-26 16:56 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2008-08-26 16:54:53 EDT
Description of problem:

register rhel 4 client
configuration -> enable config mang link -> choose system, click button enable spacewalk config mang.

ISE..



2008-08-26 16:40:50,208 [TP-Processor3] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class com.redhat.rhn.common.db.WrappedSQLException

2008-08-26 16:40:50,239 [TP-Processor3] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back

javax.servlet.ServletException: No more data to read from socket

        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)

        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)

        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)

        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)

        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)

        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)

        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(A
Comment 1 wes hayutin 2008-08-26 16:56:20 EDT
Created attachment 315050 [details]
catalina.out

full trace
Comment 2 Devan Goodwin 2008-09-05 11:07:35 EDT
Bumping to spacewalk 0.3.
Comment 3 Justin Sherrill 2008-10-13 13:12:30 EDT
Looks like this is just an issue with  the 'web.product_name' being set to the wrong thing.

If it's set to:

web.product_name= "Spacewalk"

it will break, if it's set to just:

web.product_name= Spacewalk

it works fine.


I looked to make sure it wasn't getting written to the config file that way and it doesn't look like it is.


-Justin

Note You need to log in before you can comment on or make changes to this bug.