Bug 46027 - wrong parsing of /etc/printcap
wrong parsing of /etc/printcap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-26 09:36 EDT by Sammy
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 09:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-06-26 09:36:17 EDT
Description of Problem:

No matter what I try kde applications are incorrectly parsing the printcap
file thus not being able to print. lpr printing works perfectly. I tried many
different variations of defining a printer, for example:

lp0: \
:sd=/var/log/lpd-lp0: \
:mx#0: \
:sh: \
:rm=129.59.116.60: \
:rp=raw: \
:lf=/var/log/lpd-errs:

gives lp0::sd as the printer name,

lp0
:sd=/var/log/lpd-lp0:mx#0:sh:rm=129.59.116.60:rp=raw:lf=/var/log/lpd-errs:

gives lp0:sd as the printer name, I tried many other variations that all
work with lpr but in kde the next item after lp0 is taken as part of the
name. If one put |HP Postscript Printer| kind of comments after lp0 it
does skip these and still bind with the next definition.

Any suggestion would be appreciated....also at some point printing used
to work!
Comment 1 Ngo Than 2004-09-20 09:01:22 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "CURRENTRELEASE" for now.

Note You need to log in before you can comment on or make changes to this bug.