Bug 460291 - system-config-samba user managment gui broken after editing a user
system-config-samba user managment gui broken after editing a user
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-samba (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 08:42 EDT by Ales Zelinka
Modified: 2009-09-02 06:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2008-08-27 08:42:52 EDT
Description of problem:
"Add user" window GUI breaks after editing any user. It looks like the "edit user" windows (with unix username as a plain label instead of dropdown select list) but behaves like "add user" - tries to add user from the label and fails because the user already exists.


Version-Release number of selected component (if applicable):
system-config-samba-1.2.41-3

How reproducible:
always

Steps to Reproduce:
1. add some-user via system-config-samba
2. edit some-user (no change is necessary, just confirm the edit window with ok button)
3. try to add another user 
  
Actual results:
window pops up, having "some-user" set as "Unix Username" without any way of changing it.


Expected results:
Normal "add user" window appears, just like at 1.

Additional info:
When you close the broken "add user" windows and try to repeat steps 2. and 3., it break even more:

Normal "add user" window appear but the dropdown list for unix user selection is overwritten by the label from "edit user" window.
Comment 1 Nils Philippsen 2008-08-27 11:23:44 EDT
Cloned for Rawhide as bug #460323.
Comment 8 errata-xmlrpc 2009-09-02 06:12:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1329.html

Note You need to log in before you can comment on or make changes to this bug.