Bug 460311 - Errata Search: searching for 'apache' results in unrelated results
Errata Search: searching for 'apache' results in unrelated results
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Matthews
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2008-08-27 10:24 EDT by Justin Sherrill
Modified: 2009-01-12 14:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 14:21:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-08-27 10:24:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:


   1. Login to RHN
   2. Make sure RHN is populated w/ systems and errata and have the Red Hat Enterprise Linux AS (v. 4 for 32-bit x86) channel synced
   3. Navagate to "Errata" on the main navigation bar
   4. Navagate to "Advanced Search" on the left pane menu
   5. The "Erratum Search" page should appear
   6. In the search box, type "apache"
   7. Make sure "All Fields" are selected in the "what to search for box"
   8. Click "search" 
  
Actual results:

Errata "RHBA-2007:0712" is included which is a cachefilesd errata and doesn't have anything to do with apache.

Expected results:
Only errata related with apache (httpd) would be present




Not sure if the scores need to be trimmed, but I wouldn't think this should be returned.
Comment 1 John Matthews 2009-01-12 14:21:53 EST
This matches because "cachefilesd"  is close to "apache"

Notice cache and apache both share "ache".

The search server is using NGrams for searching which allows flexibility on spelling, therefore hits like this will show up.

The hits returned are ordered by score, so the better matches will be higher on the return list.

Note You need to log in before you can comment on or make changes to this bug.