Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 460374 - Can't submit because of false msgfmt -c error
Summary: Can't submit because of false msgfmt -c error
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora Localization
Classification: Fedora
Component: Website
Version: unspecified
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dimitris Glezos
QA Contact: Diego Búrigo Zacarão
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-27 20:34 UTC by Peter van Egdom
Modified: 2009-07-03 20:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-27 22:22:32 UTC


Attachments (Terms of Use)

Description Peter van Egdom 2008-08-27 20:34:39 UTC
Description of problem:

When I try to submit a fully translated "system-config-printer.master.nl.po" file to the "system-config-printer" master branch via Transifex, the following error appears :

  Error: The PO file you submitted doesn't pass the checks for correctness.
  Please run `msgfmt -c` on it and correct the errors before submitting.

Although the "system-config-printer.master.nl.po" appears to be OK :

  [peterve@pavilion ~]$ msgfmt -v -c system-config-printer.master.nl.po 
  523 translated messages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Submit "system-config-printer.master.nl.po" via Transifex.
2.
3.
  
Actual results:

 Error: ....

Expected results:

 File submitted ...

Additional info:

Comment 1 Piotr Drąg 2008-08-27 21:14:08 UTC
Seems to happen on every module (checked in liveusb-creator, packagekit, pavucontrol, pulseaudio, system-config-printer and some more...).

Comment 2 Piotr Drąg 2008-08-27 22:22:32 UTC
This issue is being tracked at https://fedorahosted.org/fedora-infrastructure/ticket/789

Comment 3 Piotr Drąg 2009-07-03 20:07:53 UTC
Mass change of component from Transifex to Website, since all our websites are handled by Transifex now.


Note You need to log in before you can comment on or make changes to this bug.