Bug 460391 - Final image fails to provide fonts for Anaconda
Final image fails to provide fonts for Anaconda
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 20:35 EDT by Mizzen
Modified: 2013-01-09 20:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 18:10:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install screen shot (58.20 KB, image/png)
2008-08-27 20:35 EDT, Mizzen
no flags Details

  None (edit)
Description Mizzen 2008-08-27 20:35:31 EDT
Created attachment 315163 [details]
install screen shot

Description of problem:
The attached screen shot is better than words......
Somewhat amusing too.

What works:
Virtual box host, Fedora 9 DVD iso. This works as it should.

What fails:
On a real F9 box, with all updates, run Pungi as:
pungi --force --nosource -G -c /root/Fedora-Build/f9-fedora.ks
pungi --force --nosource -C -B -I --nosplitmedia -c /root/Fedora-Build/f9-fedora.ks

The ks file contains:
repo --name=fedora --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-9&arch=$basearch
# repo --name=fedora-source --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-9&arch=$basearch
repo --name=fedora-updates --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f9&arch=$basearch
repo --name=fedora-updates-source --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-source-f9&arch=$basearch

%packages
@core
@base
tcsh
@base-x
pungi
kernel*
-kernel*debug*
-kernel-kdump*
-kernel-PAE*
-kernel-xen*
-syslog-ng
-kmod-nvidia*PAE
# Hardware stuff
@hardware-support
@dial-up
# Desktop Packages
@gnome-desktop
echo-icon-theme
# Compose Needs
anaconda-runtime
cracklib-python
iscsi-initiator-utils
memtest86+
vnc-server
# Size removals
# -gimp-help
# -java-1.6.0-openjdk-src
# -xorg-x11-docs
# -kernel-doc
# -java-1.5.0-gcj-src
# -java-1.5.0-gcj-devel
# -libgcj-src
# -*javadoc*
%end


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
see above
  
Actual results:
When the install begins, as soon as the anaconda GUI comes up, there are no characters at all. Just rectangular boxes where the letter should be - can not read anything.


Expected results:
Usable install image


Additional info:
After a long time with Google, searching the anaconda bugs and pungi bugs, I could find nothing similar.
So, I could be doing something wrong to invoke this error - but I have no idea what that might be.
Comment 1 Jesse Keating 2008-11-04 18:10:06 EST
This is due to F9 needing you to specify in your kickstart config all the bits and parts that anaconda needs, including fonts.

With rawhide leading up to F10, anaconda buildinstall will fetch the things it needs form the repos that pungi uses, so this is no longer a problem.  I'm closing this nextrelease.

Note You need to log in before you can comment on or make changes to this bug.