Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 460413 - unable to open rpmbd - debug file attached
Summary: unable to open rpmbd - debug file attached
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm
Version: 5.2
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: rc
: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
: 461079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-28 06:08 UTC by Nadeer
Modified: 2008-09-11 07:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-11 07:14:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
debug file - RPM error (1.21 KB, application/octet-stream)
2008-08-28 06:17 UTC, Nadeer
no flags Details

Description Nadeer 2008-08-28 06:08:58 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nadeer 2008-08-28 06:17:54 UTC
Created attachment 315174 [details]
 debug file - RPM error

I'm unable to install any RPM file to new release of RHEL 5U2 server. The debug file is below also attached . kindly give the solution 
===============================================
Component: pirut
Summary: TBbc99d12e config.py:752:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 490, in ?
    main()
  File "/usr/sbin/pirut", line 483, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 67, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 137, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 118, in doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 164, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 685, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 752, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x9079eac>
distroverpkg: redhat-release
==============================================================

Comment 2 Panu Matilainen 2008-09-11 07:02:15 UTC
*** Bug 461079 has been marked as a duplicate of this bug. ***

Comment 3 Panu Matilainen 2008-09-11 07:14:25 UTC
yum/pirut should handle the case of rpmdb open failing more gracefully than
dumping a traceback, but... as a quick googling for "TypeError: rpmdb open
failed" would have told you, the following will likely to fix the issue:
# rm -f /var/lib/rpm/__*
# rpm --rebuilddb

If not, feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.