Bug 460431 - system-config-samba dies with misleading message when pdbedit can't contact LDAP server
system-config-samba dies with misleading message when pdbedit can't contact L...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-samba (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Nils Philippsen
qe-baseos-daemons
:
Depends On: 460437
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 05:34 EDT by Ales Zelinka
Modified: 2013-04-15 06:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 06:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2008-08-28 05:34:45 EDT
Description of problem:
When samba is configured to use LDAP for storing account information and the LDAP server is not available (or some other error occures), system-config-samba dies with traceback.

Version-Release number of selected component (if applicable):
system-config-samba-1.2.41-3.el5.noarch

How reproducible:
always

Steps to Reproduce:
1. set "passdb backend" to "ldapsam:ldap://hostname-without-working-ldap-server"
2. run system-config-samba and wait for pdbedit to timeout

  
Actual results:
raceback (most recent call last):
  File "/usr/share/system-config-samba/system-config-samba.py", line 41, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 86, in __init__
    self.samba_user_data = sambaUserData.SambaUserData(self)
  File "/usr/share/system-config-samba/sambaUserData.py", line 42, in __init__
    self.readSmbPasswords()
  File "/usr/share/system-config-samba/sambaUserData.py", line 59, in readSmbPasswords
    raise RuntimeError, (_("You do not have permission to execute %s." % pdbeditcmd))
RuntimeError: You do not have permission to execute /usr/bin/pdbedit.


Expected results:
Sane error message telling what really has happened.

Additional info:
Comment 1 Nils Philippsen 2008-08-28 06:20:13 EDT
Cloned for Rawhide as bug #460437.
Comment 14 RHEL Product and Program Management 2009-11-06 13:50:09 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 16 RHEL Product and Program Management 2010-08-09 14:38:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 Nils Philippsen 2013-04-15 06:04:28 EDT
Unfortunately it's too late in the life cycle of Red Hat Enterprise Linux 5 to fix this bug. The upcoming 5.10 update is going to be the first production phase 2 release of Red Hat Enterprise Linux 5. From phase 2 on we'll be addressing primarily security and critical issues, therefore I'll close this bug. The system-config-samba component isn't contained in Red Hat Enterprise Linux version 6 or later.

Note You need to log in before you can comment on or make changes to this bug.