Bug 460438 - comps needs update because of rpm-apidocs
comps needs update because of rpm-apidocs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.3
All Linux
medium Severity high
: beta
: ---
Assigned To: Brock Organ
Alexander Todorov
http://errata.devel.redhat.com/errata...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 06:06 EDT by Jindrich Novy
Modified: 2013-07-02 19:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:18:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2008-08-28 06:06:18 EDT
Description of problem:
There is planned rebase of RPM in RHEL5.3. The new packages come with the new subpackage named rpm-apidocs. comps need to be updated because of that. Otherwise compose won't find rpm-apidocs and therefore it's missing from the errata.

Thanks!

Relevant URLs:
build: https://brewweb.devel.redhat.com/buildinfo?buildID=74294
errata: http://errata.devel.redhat.com/errata/info/7663
Comment 1 RHEL Product and Program Management 2008-08-28 07:30:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Daniel Mach 2008-08-29 04:44:34 EDT
The subackage has been pulled into last nightly compose via NPLB (No Package Left Behind) feature.
There's no need to do a comps change unless the subpackage should appear in anaconda package list.

Jindrich, does it make sense to add it to the package list in anaconda?
In this case, I'd prefer *not* to add it, since it's a docs file which wouldn't be frequently used.
Comment 3 Jindrich Novy 2008-08-29 06:18:43 EDT
(In reply to comment #2)
> Jindrich, does it make sense to add it to the package list in anaconda?
> In this case, I'd prefer *not* to add it, since it's a docs file which wouldn't
> be frequently used.

Please don't add it to the list in anaconda if the anaconda guys need only the functional part. Missing rpm-apidocs won't affect a functionality of rpm and it was also one of the reasons for splitting it into a separate subpackage :)
Comment 11 errata-xmlrpc 2009-01-20 16:18:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0133.html

Note You need to log in before you can comment on or make changes to this bug.