Bug 460522 - RFE: smart autoscrolling by middle click on scrollbar in firefox
RFE: smart autoscrolling by middle click on scrollbar in firefox
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-08-28 08:45 EDT by Muayyad Alsadi
Modified: 2008-08-28 10:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-28 10:43:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 452606 None None None Never

  None (edit)
Description Muayyad Alsadi 2008-08-28 08:45:45 EDT
I have a good idea for better firefox UI

it's to make middle click assigned to autoscrolling only in the scrollbar
so that it won't interferes with what ever Linux users do with there middle
mouse button

most people are not aware that firefox do have autoscrolling
and even when they know about it, they will disable it back
because we need to copy and paste with middle mouse button
and we do other things with it


middle clicking the scrollbar is not strange it's there in other web browsers
like IE and opera

and to make Windows users happy this limiting the autoscrolling region should
be only defaults in linux

ie. instead of having autoscrolling on and off
we should have autoscrolling full or smart (or limited)
Comment 1 Matěj Cepl 2008-08-28 10:43:36 EDT
Thank yo ufor filing this bug upstream as well, because we believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.