Bug 460545 - Keyboard layout broken after group change
Keyboard layout broken after group change
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 10:49 EDT by Milan Kerslager
Modified: 2008-11-14 07:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 00:29:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "xkbcomp :0 -" (50.60 KB, text/plain)
2008-08-28 10:49 EDT, Milan Kerslager
no flags Details
Requested output (60.46 KB, text/plain)
2008-08-29 06:25 EDT, Milan Kerslager
no flags Details
Stderr output of xkbcomp command (3.14 KB, application/octet-stream)
2008-08-29 06:26 EDT, Milan Kerslager
no flags Details
Setxkbmap output (with -print) (380 bytes, text/plain)
2008-08-29 06:28 EDT, Milan Kerslager
no flags Details
Output of: setxkbmap -layout "cz,us" -option "grp:alt_shift_toggle" -compat "complete+ledscroll(group_lock)" -print (380 bytes, text/plain)
2008-09-18 12:59 EDT, Milan Kerslager
no flags Details
Error messages from: setxkbmap ... | xkbcomp - :0 (3.14 KB, text/plain)
2008-09-18 13:01 EDT, Milan Kerslager
no flags Details
xkbcomp -xkb :0 out.xkb (63.77 KB, text/plain)
2008-09-18 13:02 EDT, Milan Kerslager
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 14373 None None None Never

  None (edit)
Description Milan Kerslager 2008-08-28 10:49:48 EDT
Created attachment 315222 [details]
Output of "xkbcomp :0 -"

I tryed 906-5 from Rawhide to solve bug #434669. Gnome uses evdev. My preferred keymap is properly activated at login (autologin by gdm). But the secondary keymap is odd (US). Space is generating weird whitespace character so I'm unable to type commands on commandline. If keyboard properties are activated, changed and saved, all works again. So there is a great progress with some outstanding issues.

Xorg.log
  https://bugzilla.redhat.com/attachment.cgi?id=315017
gconftool-2 --dump /desktop/gnome/peripherals/keyboard output
  https://bugzilla.redhat.com/attachment.cgi?id=315018
setxkbmap -print output:
  https://bugzilla.redhat.com/attachment.cgi?id=315019
xev output:
  https://bugzilla.redhat.com/attachment.cgi?id=315020
Comment 1 Milan Kerslager 2008-08-28 11:11:00 EDT
Only 1 out of my 8 machines with F9 installed has this issue.
Comment 2 Peter Hutterer 2008-08-28 20:17:39 EDT
Please run the following command:
setxkbmap -layout "cz,us" -option "grp:alts_toggle, grp:alt_shift_toggle" -compat "complete+ledscroll(group_lock)" | xkbcomp -xkb - out.xkb

and then attach the out.xkb file.

Why?

The loaded keymap states:
key <SPCE> {
        type[group1]= "FOUR_LEVEL",
        symbols[Group1]= [           space,           space,    nobreakspace,    nobreakspace ],
        symbols[Group2]= [    nobreakspace,    nobreakspace ]
    };

This means that in group 2 (US layout), space always generates a nbsp. Now we need to find out whether this is xkbcomp, or the rules, or gnome that causes this broken keymap.

Also please state the version of xorg-x11-xkb-utils.
Comment 3 Milan Kerslager 2008-08-29 06:25:15 EDT
Created attachment 315346 [details]
Requested output

I had to add "-print" option to the setxkbmap command as it produced no output without this option.
Also I logged setxkbmap output and xkbcomp error output.
Comment 4 Milan Kerslager 2008-08-29 06:26:21 EDT
Created attachment 315347 [details]
Stderr output of xkbcomp command
Comment 5 Milan Kerslager 2008-08-29 06:28:55 EDT
Created attachment 315348 [details]
Setxkbmap output (with -print)

I have latest official F9 package: xorg-x11-xkb-utils-7.2-4.fc9.i386
Comment 6 Peter Hutterer 2008-09-02 06:08:02 EDT
Reading that, the issue could be either gnome or xkm.

The next thing to test would be:
setxkbmap ... | xkbcomp - :0 (this loads the correct xkb description into the server)
xkbcomp -xkb :0 out.xkb (dumps server's description into out.xkb)

if out.xkb differs from the xkb file we got before, then it's the xkm format or the server's handling of the files. Otherwise, it is gnome.
Comment 7 Milan Kerslager 2008-09-18 12:59:46 EDT
Created attachment 317093 [details]
Output of: setxkbmap -layout "cz,us" -option "grp:alt_shift_toggle" -compat "complete+ledscroll(group_lock)" -print
Comment 8 Milan Kerslager 2008-09-18 13:01:27 EDT
Created attachment 317094 [details]
Error messages from: setxkbmap ... | xkbcomp - :0
Comment 9 Milan Kerslager 2008-09-18 13:02:48 EDT
Created attachment 317095 [details]
xkbcomp -xkb :0 out.xkb
Comment 10 Milan Kerslager 2008-09-18 13:05:03 EDT
I updated to the latest F9 newkey (had to recreate repo files).
Sorry for slow answers, the machine is located in Internet cafe :-)
Will try be faster next time.
Comment 11 Peter Hutterer 2008-09-18 23:49:30 EDT
Finally found the upstream bugreport:

xorg-1.4.0.90: Alternative layouts don't work due to groups "invented" by the server. (http://bugs.freedesktop.org/show_bug.cgi?id=14373)

I can reproduce it here with gdm autologin, [cz,us] in gnome and the alts_toggle + alt_shift_toggle options. Then, when I hit the Alt key, the second group is busted. I can't reproduce it after running setxkbmap though.
Comment 12 Milan Kerslager 2008-09-20 02:02:06 EDT
Is there a patch/build with fix?
Why this bug hit only one of my machines?
Comment 13 Peter Hutterer 2008-09-21 22:55:39 EDT
Patch sent to xorg list for review:
http://lists.freedesktop.org/archives/xorg/2008-September/038743.html

> Why this bug hit only one of my machines?

Do you have the same xkb configuration on all of them? The bug is only triggered if you don't hit a key before gnome sets the keyboard mapping, i.e. if you have autologin. Other than that - no idea.
Comment 14 Milan Kerslager 2008-09-22 05:26:42 EDT
After the latest update the bug is back on all my machines.

xorg-x11-server-common-1.5.0-1.fc9.i386
xorg-x11-drv-evdev-2.0.4-1.fc9.i386
xorg-x11-server-Xorg-1.5.0-1.fc9.i386
Comment 15 Peter Hutterer 2008-09-22 23:10:27 EDT
Can you please try the packages at [1]? They include the patch sent to the ML as mentioned in Comment #13.

[1] http://koji.fedoraproject.org/scratch/whot/task_837832/
Comment 16 Milan Kerslager 2008-09-25 12:39:21 EDT
I updated machines with todays F9 updates to 1.5.0-2.fc9 with no luck.
Then I downloaded your 1.5.0-3.fc9 and the keymap seems to be fixed and I see no problem so far. I updated these packages:

xorg-x11-server-common-1.5.0-3.fc9.i386.rpm
xorg-x11-server-Xorg-1.5.0-3.fc9.i386.rpm

Thank you a lot! Now please make this to the F9/F10 updates if possible.
Comment 18 Fedora Update System 2008-10-26 22:49:31 EDT
xorg-x11-server-1.5.2-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.2-2.fc9
Comment 19 Fedora Update System 2008-11-03 00:51:23 EST
xorg-x11-server-1.5.2-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-server-1.5.2-3.fc9
Comment 20 Fedora Update System 2008-11-14 07:45:09 EST
xorg-x11-server-1.5.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.