Bug 460548 - ERROR with rpm_check_debug vs depsolve
ERROR with rpm_check_debug vs depsolve
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 11:01 EDT by John Reiser
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 13:23:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2008-08-28 11:01:38 EDT
Description of problem: Today's "yum update" (Thu.Aug.28) aborts with an error in rpm_check_debug.


Version-Release number of selected component (if applicable):
yum-3.2.18-1.fc10.noarch


How reproducible: always


Steps to Reproduce:
1.yum --exclude redhat-lsb update
2.
3.
  
Actual results:
  [snip]
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libcamel-1.2.so.12 is needed by (installed) totem-pl-parser-2.23.3-1.fc10.i386
Complete!
(1, [u'Please report this error in bugzilla'])


Expected results:
Normal completion

Additional info:
Comment 1 John Reiser 2008-08-28 11:04:58 EDT
Problem persists after "yum update yum", which updates to yum-3.2.19-1.fc10.noarch .
Comment 2 James Antill 2008-08-28 11:10:47 EDT
 Can you post the full "yum update -d 8" information?
Comment 3 Seth Vidal 2008-08-28 11:11:43 EDT
Can you post the full log of what you're seeing

running it with yum -d 7 would even be more hopeful.

thanks
Comment 4 John Reiser 2008-08-28 12:29:49 EDT
I started doing binary search on the list of packages to be updated ("yum --exclude redhat-lsb update <half-of-list>") before I received Comment #2 and Comment #3.

The culprit was:
-----
# yum remove totem-pl-parser
Dependencies Resolved

================================================================================
 Package                Arch        Version              Repository       Size 
================================================================================
Removing:
 totem-pl-parser        i386        2.23.3-1.fc10        installed        1.8 M
 totem-pl-parser        i386        2.23.3-2.fc10        installed        1.8 M
Removing for dependencies:
 rhythmbox              i386        0.11.6-6.fc10        installed         11 M
 totem                  i386        2.23.4-1.fc10        installed        5.5 M
 totem-gstreamer        i386        2.23.4-1.fc10        installed        132 k
 totem-mozplugin        i386        2.23.4-1.fc10        installed        486 k
 totem-nautilus         i386        2.23.4-1.fc10        installed         48 k
 totem-xine             i386        2.23.4-1.fc10        installed         85 k

-----
So there were two versions of totem-pl-parser already installed:
   2.23.3-1.fc10
   2.23.3-2.fc10

After removing totem-pl-parser, then there were no problems with updating the rest (except I still excluded redhat-lsb for some reason).
Comment 5 James Antill 2008-08-28 13:23:42 EDT
 Ok, "package-cleanup --dupes" might help you find the problem quicker next time.

Note You need to log in before you can comment on or make changes to this bug.