Bug 460549 - appliance-creator --logfile only works with -d
appliance-creator --logfile only works with -d
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: appliance-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Huff
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 11:02 EDT by James Laska
Modified: 2013-09-02 02:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 13:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-08-28 11:02:37 EDT
Description of problem:

When using the --logfile parameter when creating an image, the logfile is empty unless you provide the -d or -v options.

I was expecting all stdout to be sent to the logfile.  Is that correct?

Version-Release number of selected component (if applicable):

appliance-tools-003-3.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. Run: appliance-tools -n ThinCrust --logfile /tmp/foo.out


Actual results:

/tmp/foo.out is empty

Expected results:

/tmp/foo.out should have all stdout messages?
Comment 1 James Laska 2008-08-28 11:11:08 EDT
Maybe this is a moot point considering the doc says what it will do :(

--logfile=FILE   Save debug information to FILE
Comment 2 David Huff 2008-09-05 12:01:05 EDT
Yea because the rest of the output is not logging info but output to sub-process calls, like yum and grub commands. 

-D
Comment 3 David Huff 2008-09-23 13:59:05 EDT
closing as not a bug

Note You need to log in before you can comment on or make changes to this bug.