This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 460581 - geode driver doesn't auto-config on XO
geode driver doesn't auto-config on XO
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-amd (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-08-28 15:32 EDT by Jeremy Katz
Modified: 2010-08-25 17:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 06:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X log (15.18 KB, text/plain)
2008-08-28 15:32 EDT, Jeremy Katz
no flags Details

  None (edit)
Description Jeremy Katz 2008-08-28 15:32:37 EDT
Created attachment 315287 [details]
X log

Running without an xorg.conf on the XO leads to errors starting X due to inability to find modes.  Log attached
Comment 1 Warren Togami 2008-08-29 00:52:21 EDT
rpm -q xorg-x11-server xorg-x11-drv-geode

http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-geode/
Did you test the latest builds here?
Comment 2 Jeremy Katz 2008-08-29 09:58:50 EDT
Would have been what was in rawhide before new bits started flowing yesterday.  I'll be doing some more builds and will try newer now that rawhide's been pushed
Comment 3 Matěj Cepl 2008-09-05 12:02:58 EDT
OK, waiting on more information.
Comment 4 Matěj Cepl 2008-09-09 16:50:58 EDT
Reporter, could you please reply to the previous question? Thank you
Comment 5 Jeremy Katz 2008-09-10 14:27:34 EDT
Still the case with today's rawhide with is 2.10.1 of the geode driver.

But based on the discussion I had with Jordan on IRC, this isn't entirely unexpected and he was going to take a look.
Comment 6 Bug Zapper 2008-11-25 21:54:00 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Peter Robinson 2009-06-26 04:29:38 EDT
I believe this is now fixed, just need some confirmation. I will test it on my XO as well as my FitPC to confirm.
Comment 8 Peter Robinson 2009-06-26 06:59:52 EDT
Actually its being used like this for the SugarLabs SOAS builds so it should be good :)
Comment 9 Kevin Fenzi 2010-08-25 17:31:39 EDT
It seems that still to this day, we have a hack in the spins-kickstarts for this bug: 

# this is a bad hack to work around #460581 for the geode
# purely to help move testing along for now
if [ \`grep -c Geode /proc/cpuinfo\` -ne 0 ]; then
  cat > /etc/X11/xorg.conf <<FOE
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
...

Can I remove this from the f14 ones?
Comment 10 Peter Robinson 2010-08-25 17:38:28 EDT
> Can I remove this from the f14 ones?

Yes! I meant to remove that in F-13 but ran out of time.

Note You need to log in before you can comment on or make changes to this bug.