Bug 460607 - [PATCH] mkinitrd fails to produce working initrd for usb root
[PATCH] mkinitrd fails to produce working initrd for usb root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-08-28 20:36 EDT by Dave Airlie
Modified: 2008-10-27 15:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 15:49:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch that supports built-in usb .hci[_-]hcd.ko (702 bytes, patch)
2008-09-03 15:26 EDT, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Dave Airlie 2008-08-28 20:36:04 EDT
Description of problem:

mkinitrd still uses /proc/usb/ for stabilising, however I don't get the mount line in my initrd at all despite have a USB root disk. If I stick sleep 15 manually instead of the stabiliser then it boots fine.

So not sure if /proc/usb is gone away or why the mount line isn't getting emitted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alexandre Oliva 2008-09-03 15:26:40 EDT
Created attachment 315677 [details]
Patch that supports built-in usb .hci[_-]hcd.ko

The problem came up because ohci-hcd et al are now built into the kernel, rather than modules.  This broke the heuristics to mount /proc/bus/usb right after loading those modules.  The attached patch fixed this problem for me.
Comment 2 Bill Nottingham 2008-10-27 15:49:47 EDT
This should already be fixed by http://git.fedorahosted.org/git/?p=mkinitrd;a=commitdiff;h=0e3a5937c49ecada201d99909cf6fa06e0163596, in 6.0.63-1.

Please reopen if it's not.

Note You need to log in before you can comment on or make changes to this bug.