Bug 460633 - directory in panel unnecessarily changed
directory in panel unnecessarily changed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-29 06:35 EDT by Tomas Mraz
Modified: 2013-07-02 19:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.6.2-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 10:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Mraz 2008-08-29 06:35:34 EDT
Reproducer:
1. change directory in panel to /foo
2. switch to bash (now with cwd in /foo), run some long running command
3. switch back to mc panels, change directory to /bar
4. switch back to bash, the long running command exits, cwd in bash is still /foo
5. switch back to mc panels again, mc switches automatically the directory to /foo

5. is the bug.

Suggestion how to fix it:
If mc finds out that the cwd of bash in 1. and 4. is the same (/foo in our case), it will not change the directory in the panel but changes the cwd in bash to /bar.
Comment 1 Jindrich Novy 2008-09-02 05:53:58 EDT
It is now fixed in rawhide.
Comment 2 Tomas Mraz 2008-09-02 06:12:56 EDT
I don't think the fix is completely right - the current behavior can be seen as regression, because now if I change cwd in the bash it will never change cwd in the panel anymore. I just wanted to put a priority on the cwd changed by user in the panel over the cwd in bash.
Comment 3 Bug Zapper 2008-11-25 21:54:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2009-06-01 06:56:07 EDT
mc-4.6.2-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/mc-4.6.2-4.fc9
Comment 5 Fedora Update System 2009-06-02 10:16:07 EDT
mc-4.6.2-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.