Bug 460686 - tomboy requires libMonoPosixHelper.so which is now in mono-devel
tomboy requires libMonoPosixHelper.so which is now in mono-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-29 13:51 EDT by Daniel Walsh
Modified: 2008-09-09 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 09:17:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2008-08-29 13:51:12 EDT
Description of problem:

Not sure if this is a mono or tomboy bug.


But tomboy will not work in rawhide without mono-devel installed.

rpm -q mono-devel
mono-devel-2.0-4.fc10.x86_64
# rpm -q tomboy    
tomboy-0.11.3-1.fc10.x86_64
Comment 1 Jeremy Katz 2008-08-29 13:57:17 EDT
Actually, this is more a problem in mono than something with tomboy.

tomboy shouldn't need to require a -devel package.  If libMonoPosixHelper is something used by mono apps (which it seems is the case), then it needs to be in the main package. 

I suspect it just got grabbed into -devel due to not having a soname
Comment 2 Paul F. Johnson 2008-08-29 18:05:52 EDT
Yeah, that's the one. Fixed in next spin for rawhide
Comment 3 Paul F. Johnson 2008-09-09 09:17:00 EDT
Marking this as closed - 2.0-5 has libMonoPosixHelper back in core

Note You need to log in before you can comment on or make changes to this bug.