Bug 460710 - knetattach desktop file cannot find executable
Summary: knetattach desktop file cannot find executable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-runtime
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-29 23:34 UTC by Michal Jaegermann
Modified: 2008-10-07 14:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-01 17:02:55 UTC
Type: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2008-08-29 23:34:08 UTC
Description of problem:

In /usr/share/applications/kde4/knetattach.desktop there is a line

Exec=knetattach

and a corresponding menu entry shows up in menus if kdebase-runtime
is installed.  But 'knetattach' is now in /usr/libexec/kde4/knetattach
(it used to be /usr/bin/knetattach in F8) and attempts to start from
menu end up with missing program.  It runs without any problems when
a full path is used.

Version-Release number of selected component (if applicable):
kdebase-runtime-4.0.5-2.fc9

Comment 1 Kevin Kofler 2008-08-29 23:55:44 UTC
That sounds like an upstream bug to me.

Comment 2 Kevin Kofler 2008-08-29 23:56:56 UTC
And IMHO the problem is that it's in libexec in the first place. libexec is for internal KDE executables, not for stuff which ends up in desktop files.

Comment 3 Than Ngo 2008-09-01 10:01:33 UTC
It's the intention to install it in libexec. The kde upstream wants to avoid the file conflict with mixed KDE3/KDE4.

The line Exec=knetattach is correct. KDE attempt to search the program
in standard path /usr/libexec/kde4/:/usr/bin.

I cannot reproduce this bug here. Could you please try again? Thanks

Comment 4 Kevin Kofler 2008-09-01 10:16:01 UTC
Maybe he's trying to run it under GNOME or something?

Comment 5 Than Ngo 2008-09-01 11:13:38 UTC
it only works under KDE, so if someone atempt to start it under other desktop enviroment it wont work. We should either make it only showed in KDE or move it back to /usr/bin.

Comment 6 Michal Jaegermann 2008-09-01 14:45:18 UTC
Maybe /usr/libexec/kde4/ is in a "standard path" in some situations
but it is definitely not in this "standard" when you have a GNOME
desktop and where knetattach shows up in a "standard" menu.

As I said before - even if /usr/libexec/kde4/ is not in PATH running
/usr/libexec/kde4/knetattach at least starts without any issues
(from a terminal window opened on a GNOME desktop too).

Comment 7 Than Ngo 2008-09-01 17:02:55 UTC
it's fixed in  kdebase-runtime-4.1.1-2


Note You need to log in before you can comment on or make changes to this bug.