Bug 460711 - Too many locales listed in language selection
Too many locales listed in language selection
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 464858
  Show dependency treegraph
 
Reported: 2008-08-29 20:31 EDT by Lauri Nurmi
Modified: 2015-01-14 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-27 18:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2008-08-29 20:31:54 EDT
Note: This bug report is written with the Live CD in mind.

Description of problem:
There are hundreds of locales listed in the GDM language selection dialog.  This is too much, finding your own language can be a time consuming task.  (That is especially because the the names are not quite in alphabetical order, even the ones with Latin letters only.)  With a Live CD, you need to do this at every boot.

The real reason causing this huge list is that a lot of languages are listed at least twice, one entry for each country where such a language is spoken.  English has 15 entries, Español has 20.  I doubt there are 20 translation teams for different variants of Spanish, so all these entries basically give you the same translation.  I know there are a few exceptions, e.g. en_GB and pt_BR.


Actual results:
A huge list of locales.


Expected results:
A shorter list of languages.


Additional info:
The shorter list could be achieved by listing each language only once.  If necessary, there could be an additional question about the country, depending on the language chosen.
Comment 1 Jens Petersen 2008-08-31 22:23:34 EDT
Hmm, perhaps using a treeview for langs with many regions would help?
Comment 2 Lauri Nurmi 2008-09-01 11:18:11 EDT
A treeview would certainly suit better than a plain list.  And of course, the tree items should be collapsed by default, otherwise the number of visible lines would be even greater than with the plain list.
Comment 3 Matthias Clasen 2008-09-04 23:13:50 EDT
No, a treeview be too complicated ui-wise. It would be much better to trim the list to the language/country combinations that actually have different translations.
Comment 4 Tony Fu 2008-09-09 23:12:40 EDT
requested by Jens Petersen (#27995)
Comment 5 fujiwara 2009-08-28 03:39:10 EDT
Regarding to trimming lang tag, I filed bugzilla.gnome 593359.
Comment 6 Matthias Clasen 2011-02-27 18:50:00 EST
Language selection has been removed from the login screen in f15
Comment 7 Ville-Pekka Vainio 2011-02-28 13:30:10 EST
(In reply to comment #6)
> Language selection has been removed from the login screen in f15

Then how is the language selected in the live CD? After login is a bit too late...

Note You need to log in before you can comment on or make changes to this bug.