Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 460720 - bugzilla needs to be approved component list aware
Summary: bugzilla needs to be approved component list aware
Keywords:
Status: CLOSED DUPLICATE of bug 463810
Alias: None
Product: Bugzilla
Classification: Community
Component: Administration
Version: 3.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-30 04:55 UTC by David Lawrence
Modified: 2013-06-24 04:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-01 16:59:39 UTC


Attachments (Terms of Use)

Description David Lawrence 2008-08-30 04:55:15 UTC
Hi,

It would be highly desirable to have a bug display if the component it
is filed against is an approved component for the nvr it is proposed
for.

Regards,
Kevin

-----

I'm probably off on a tangent here but I have a dream that it would work somewhat like this

Program Managers, via a web interface, maintain the list of approved components.

Bugzilla could then fire off the rules to see what tasks are possible for this bug. For example, in the this case it would fire the "what nvr's can this user propose on this bug?" rule. Which would simply inspect the following conditions

-1- is this bug's component on any approved n-v-r list?
-2- does this user have permissions to propose to those n-v-r found in (1)?

If (1) & (2) are satisfied then have the UI display options that let's the user do it. otherwise they don't see any option for that. 

-----

That sounds pretty right but I don't think a user should be stopped from
proposing a bug against a non-approved component.

You bring up an interesting concept here: "guided state transition".
That is, bugzilla should not allow users to set flags that put a bug in
an unacceptable state. Acceptable states would be a function of
component, CDW, and where we are in the update cycle. Great thinking
Kev!

Comment 1 David Lawrence 2008-10-01 16:59:39 UTC

*** This bug has been marked as a duplicate of bug 463810 ***


Note You need to log in before you can comment on or make changes to this bug.