Bug 460739 - Assertion 'error != NULL' failed
Assertion 'error != NULL' failed
Status: CLOSED DUPLICATE of bug 458586
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-08-30 13:53 EDT by Alessandro Pagnin
Modified: 2008-09-03 03:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-03 03:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alessandro Pagnin 2008-08-30 13:53:20 EDT
When I start system-config-firewall I can see the GUI for one second and then it exit with this errors:

(system-config-firewall.py:20191): GLib-GIO-CRITICAL **: g_simple_async_result_set_from_error: assertion `error != NULL' failed
/usr/share/system-config-firewall/fw_gui.py:2149: Warning: g_error_free: assertion `error != NULL' failed
  result = dialog.run()

(system-config-firewall.py:20191): GLib-GIO-CRITICAL **: g_simple_async_result_set_from_error: assertion `error != NULL' failed

(system-config-firewall.py:20191): GLib-GIO-WARNING **: (gfile.c:5244):IA__g_file_load_partial_contents_finish: runtime check failed: (g_simple_async_result_get_source_tag (simple) == g_file_load_contents_async)
Comment 1 Michal Schmidt 2008-09-02 09:26:25 EDT
Looks similar to bug 458586. Do you have a blank medium in your CD/DVD drive?
Comment 2 Alessandro Pagnin 2008-09-02 09:28:27 EDT
No, i'm sorry
Comment 3 Michal Schmidt 2008-09-02 10:36:55 EDT
Does nautilus crash with the same messages when you run it from root's shell?
Comment 4 Alessandro Pagnin 2008-09-02 13:44:32 EDT
Yes !
Comment 5 Michal Schmidt 2008-09-03 03:21:24 EDT

*** This bug has been marked as a duplicate of bug 458586 ***

Note You need to log in before you can comment on or make changes to this bug.