Bug 460740 - irreversible screen lock
irreversible screen lock
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 14:43 EDT by Andrei Gaponenko
Modified: 2008-11-29 20:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-29 20:40:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 176506 None None None Never

  None (edit)
Description Andrei Gaponenko 2008-08-30 14:43:53 EDT
Hi,

If the screen is locked while the keyboard is in a non-English
layout, it is impossible to unlock the screen.  This is using 
KDE desktop in Fedora 9.  The unlock screen
dialog lacks a keyboard layout switch that used to be present in
an earlier version.  (I think I saw it in the version of KDE used with 
RedHat 4.)

Andrei
Comment 1 Steven M. Parrish 2008-09-06 19:39:37 EDT
Thanks for the report.  I checked upstream and could not find a matching bug.Please file a bug report in the the upstream bugzilla located at http://bugs.kde.org for the particular component involved.

Once you've filed your bug report to the upstream bugzilla, please add the upstream info to this report. We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 2 Andrei Gaponenko 2008-09-13 18:48:57 EDT
The problem seems to be intermittent.  I did not realize that when creating
this bug report.  In several months I lost my sessions several times
because of this problem.  But usually there *is* a keyboard layout switch
on the locked screen.  

Many KDE packages on my Fedora 9 were updated last
week after the RPM re-signing etc.   I suggest to close this bug 
for now;  if this problem occurs again I'll revive this thread and
report upstream.

Thank you,
Andrei
Comment 3 Andrei Gaponenko 2008-11-29 18:24:01 EST
Hi,

OK, I understood why sometimes there is a keyboard layout switch
and sometime not when the screen is locked.  These are interfaces
from two different programs:  krunner_lock is aware of keyboard
layout, why xlock is not.

Reported upstream at 
https://bugs.kde.org/show_bug.cgi?id=176506

Andrei

PS.  A brute force workaround would be to uninstall the xlockmore rpm.
But it is needed by fvwm, which I also use, so for me that's not an option.

PPS.  I managed to recover a session xlock-ed with a wrong keyboard
layout by logging into another VT and killing xlock.  
That removed the lock and left the X and the KDE session in a usable state.
Comment 4 Rex Dieter 2008-11-29 20:40:02 EST
thanks, tracking upstream.
Comment 5 Rex Dieter 2008-11-29 20:40:32 EST
fwiw, I'm not aware of kde *ever* using xlock.

Note You need to log in before you can comment on or make changes to this bug.