Bug 460758 - sometimes nautilus does not start
sometimes nautilus does not start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-08-31 02:19 EDT by cornel panceac
Modified: 2008-11-12 03:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 15:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the /var/log/messages form the session when nautilus doesn't start (197.47 KB, text/plain)
2008-08-31 02:19 EDT, cornel panceac
no flags Details
the xsession-errors when nautilus does not start (or at least the "desktop") in f9 (2.39 KB, text/x-log)
2008-10-17 10:20 EDT, cornel panceac
no flags Details
Results of nautilus gdb session (17.12 KB, text/plain)
2008-10-24 12:17 EDT, npiotrowski
no flags Details
Results of "nautilus --sync" gdb session (17.57 KB, text/plain)
2008-10-24 14:22 EDT, npiotrowski
no flags Details

  None (edit)
Description cornel panceac 2008-08-31 02:19:09 EDT
Created attachment 315433 [details]
the /var/log/messages form the session when nautilus doesn't start

Description of problem:

sometimes, when after i log into gnome, nautilus doesn't start.

Version-Release number of selected component (if applicable):

$ rpm -q nautilus
nautilus-2.23.90-2.fc10.i386


How reproducible:
sometimes

Steps to Reproduce:
1.log into gnome
2.
3.
  
Actual results:
nautilus doesn't start

Expected results:
nautilus starts

Additional info:
same behaviour i've noticed on several hardware-different fedora 9 systems: one hp xw workstation, one x40 thinkpad, one home-built gigabyte mobo amd x2 system and one friend's benq joybook.
Comment 1 Matthias Clasen 2008-10-03 23:59:12 EDT
Looks like nautilus segfaults here:

Aug 31 08:35:46 localhostlocaldomain kernel: nautilus[3151] general protection ip:12015b sp:bfee5b50 error:0 in ld-2.8.90.so[110000+20000]


Are you still seeing this with current rawhide ?
Comment 2 cornel panceac 2008-10-04 01:29:59 EDT
i'll report as soon as i'l see it, on my f10beta x86_64 rawhide, or on my f9 systems, where it appeared often.if necessary i'll install f10beta x86.
thank you.
Comment 3 Alexander Larsson 2008-10-17 05:20:10 EDT
If you manually start nautilus, does it ever crash? Start with "nautilus", then quit with "nautilus -q" and try again a bunch of times. That way we should be able to get some debugging information if you can repeat the crash.

Also, when this happens, do you have anything in ~/.xsession-errors?
Comment 4 cornel panceac 2008-10-17 10:20:17 EDT
Created attachment 320668 [details]
the xsession-errors when nautilus does not start (or at least the "desktop") in f9

first time i run nautilus from terminal it started in background.
nautilus -q 
just closed the browser window.
at the next try, i got:

$ nautilus 
Initializing nautilus-flac-converter extension
seahorse nautilus module initialized

** (nautilus:4071): WARNING **: Unable to add monitor: Not supported
seahorse nautilus module shutdown
Shutting down nautilus-flac-converter extension

wich includes the output caused by
nautilus -q
on another terminal.

please note that the second time (and third) nautilus no longer started in background and nautilus -q has no output in it's own terminal.
Comment 5 cornel panceac 2008-10-17 10:25:19 EDT
i forgot: when i start 
nautilus
from terminal, the "desktop" does not start.
and
in the last days, on f9 nautilus usually does not start.
and
i haven't seen this bug recently on f10beta.
Comment 6 Alexander Larsson 2008-10-17 13:12:23 EDT
Pretty weird, its looks like it just decide to cleanly exit...
Comment 7 npiotrowski 2008-10-19 15:15:39 EDT
I have similar problem with nautilus. After update, from 17.10.2008 nautilus stopped working correctly. 

After login to gnome the window:
"Nautilus cannot be used now, due to an unexpected error." with these details appears:
"Nautilus cannot be used now, due to an unexpected error from Bonobo when attempting to locate the factory. Killing bonobo-activation-server and restarting Nautilus may help fix the problem."

This problem occurs when I configure dual display mode (Separate X screen), with one display is ok. Before 2008.10.17 configuration with dual display mode was ok.


[norbert@nelson ~]$ uname -a
Linux nelson.localdomain 2.6.27.2-23.rc1.fc10.i686.PAE #1 SMP Thu Oct 16 23:55:32 EDT 2008 i686 i686 i386 GNU/Linux


[norbert@nelson ~]$cat .xsession-errors

imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: yes
Is Qt supported: no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-BLF1A5CEoq,guid=c63ebb1a34a39f9c6bd429f548f9a616
GTK_IM_MODULE: 
QT_IM_MODULE: 
XMODIFIERS: @im=imsettings
IMSETTINGS_MODULE: none


(imsettings-start:3019): IMSettings-WARNING **: Failed to invoke a method `StartIM':
  No XIM server is available in none
Failed to start IM process `none'
Window manager warning: Failed to read saved session file /home/chrz/.config/metacity/sessions/108a44e6ddcf8e40e8122432053650839000000029360030.ms: Failed to open file '/home/chrz/.config/metacity/sessions/108a44e6ddcf8e40e8122432053650839000000029360030.ms': No such file or directory
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1198 error_code 8 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

** (nautilus:3342): WARNING **: Unable to add monitor: Not supported


This is the list what was updated 17.10.2008:

Oct 17 16:53:14 Updated: m17n-db-1.5.2-3.fc10.noarch
Oct 17 16:53:15 Updated: m17n-contrib-1.1.7-4.fc10.noarch
Oct 17 16:53:19 Updated: redhat-menus-10.0.0-1.fc10.noarch
Oct 17 16:53:20 Updated: python-slip-0.1.15-1.fc10.noarch
Oct 17 16:53:20 Updated: python-slip-gtk-0.1.15-1.fc10.noarch
Oct 17 16:53:21 Updated: python-slip-dbus-0.1.15-1.fc10.noarch
Oct 17 16:53:25 Updated: xkeyboard-config-1.4-3.fc10.noarch
Oct 17 16:53:39 Updated: texlive-texmf-2007-26.fc10.noarch
Oct 17 16:53:39 Updated: python-urlgrabber-3.0.0-10.fc10.noarch
Oct 17 16:53:39 Updated: xorg-x11-server-common-1.5.2-4.fc10.i386
Oct 17 16:53:41 Updated: 6:kdelibs-common-4.1.2-5.fc10.i386
Oct 17 16:53:44 Updated: texlive-texmf-dvips-2007-26.fc10.noarch
Oct 17 16:53:45 Updated: kernel-firmware-2.6.27-13.fc10.noarch
Oct 17 16:54:01 Updated: selinux-policy-3.5.12-2.fc10.noarch
Oct 17 16:54:24 Updated: selinux-policy-targeted-3.5.12-2.fc10.noarch
Oct 17 16:54:49 Updated: texlive-texmf-fonts-2007-26.fc10.noarch
Oct 17 16:54:49 Updated: m17n-contrib-urdu-1.1.7-4.fc10.noarch
Oct 17 16:54:50 Updated: m17n-contrib-marathi-1.1.7-4.fc10.noarch
Oct 17 16:54:50 Updated: m17n-db-thai-1.5.2-3.fc10.noarch
Oct 17 16:55:02 Installed: kernel-PAE-devel-2.6.27-13.fc10.i686
Oct 17 16:55:13 Installed: kernel-devel-2.6.27-13.fc10.i686
Oct 17 16:55:13 Updated: ca-certificates-2008-7.noarch
Oct 17 16:55:21 Updated: kernel-headers-2.6.27-13.fc10.i386
Oct 17 16:55:24 Updated: un-core-fonts-dotum-1.0.2-0.6.080608.fc10.noarch
Oct 17 16:55:29 Updated: gnome-desktop-2.24.0-7.fc10.i386
Oct 17 16:55:32 Updated: initscripts-8.84-1.i386
Oct 17 16:55:33 Updated: eel2-2.24.0-5.fc10.i386
Oct 17 16:55:35 Updated: bluez-libs-4.13-3.fc10.i386
Oct 17 16:55:36 Updated: openldap-2.4.12-1.fc10.i386
Oct 17 16:55:37 Updated: xorg-x11-server-Xorg-1.5.2-4.fc10.i386
Oct 17 16:55:47 Updated: 6:kdelibs-4.1.2-5.fc10.i386
Oct 17 16:55:48 Updated: nautilus-extensions-2.24.0-3.fc10.i386
Oct 17 16:55:49 Updated: netpbm-10.35.53-1.fc10.i386
Oct 17 16:55:51 Updated: scim-libs-1.4.7-35.fc10.i386
Oct 17 16:55:51 Updated: libusb-0.1.12-19.fc10.i386
Oct 17 16:56:02 Updated: gnome-session-2.24.0-11.fc10.i386
Oct 17 16:56:04 Updated: imsettings-libs-0.105.0-2.fc10.i386
Oct 17 16:56:10 Updated: telepathy-glib-0.7.17-1.fc10.i386
Oct 17 16:56:18 Updated: imsettings-0.105.0-2.fc10.i386
Oct 17 16:56:28 Updated: gnome-settings-daemon-2.24.0-13.fc10.i386
Oct 17 16:56:38 Updated: bluez-gnome-1.8-3.fc10.i386
Oct 17 16:56:38 Updated: yum-metadata-parser-1.1.2-10.fc10.i386
Oct 17 16:56:40 Updated: nash-6.0.67-1.fc10.i386
Oct 17 16:56:41 Updated: xorg-x11-drv-i810-2.4.2-12.fc10.i386
Oct 17 16:56:45 Updated: ghostscript-8.63-3.fc10.i386
Oct 17 16:56:47 Updated: system-config-printer-libs-1.0.8-5.fc10.i386
Oct 17 16:56:58 Updated: 1:bug-buddy-2.24.0-3.fc10.i386
Oct 17 16:56:59 Updated: mpfr-2.3.2-1.fc10.i386
Oct 17 16:57:00 Updated: bluez-4.13-3.fc10.i386
Oct 17 16:57:01 Updated: scim-1.4.7-35.fc10.i386
Oct 17 16:57:02 Updated: telepathy-gabble-0.7.10-1.fc10.i386
Oct 17 16:57:16 Updated: nautilus-2.24.0-3.fc10.i386
Oct 17 16:57:22 Updated: 6:kdelibs-devel-4.1.2-5.fc10.i386
Oct 17 16:57:22 Updated: xorg-x11-drv-ati-6.9.0-27.fc10.i386
Oct 17 16:57:23 Updated: openldap-clients-2.4.12-1.fc10.i386
Oct 17 16:57:23 Updated: bluez-alsa-4.13-3.fc10.i386
Oct 17 16:57:46 Updated: 1:gedit-2.24.0-4.fc10.i386
Oct 17 16:57:49 Updated: 2:ntfs-3g-1.5012-1.fc10.i386
Oct 17 16:57:51 Updated: 1:nfs-utils-1.1.3-6.fc10.i386
Oct 17 16:57:51 Updated: htop-0.8.1-1.fc10.i386
Oct 17 16:57:52 Updated: portreserve-0.0.3-2.fc10.i386
Oct 17 16:57:53 Updated: 1:NetworkManager-vpnc-0.7.0-0.11.svn4175.fc10.i386
Oct 17 16:57:54 Updated: system-config-printer-1.0.8-5.fc10.i386
Oct 17 16:57:56 Updated: yum-3.2.19-5.fc10.noarch
Oct 17 16:57:56 Updated: gnome-session-xsession-2.24.0-11.fc10.i386
Oct 17 16:57:57 Updated: netpbm-devel-10.35.53-1.fc10.i386
Oct 17 16:57:59 Updated: openldap-devel-2.4.12-1.fc10.i386
Oct 17 16:58:00 Updated: eel2-devel-2.24.0-5.fc10.i386
Oct 17 16:58:02 Updated: system-config-services-0.99.24-1.fc10.noarch
Oct 17 16:58:03 Updated: gnome-desktop-devel-2.24.0-7.fc10.i386
Oct 17 16:58:06 Updated: setroubleshoot-plugins-2.0.9-1.fc10.noarch
Oct 17 16:58:08 Updated: setroubleshoot-server-2.0.12-1.fc10.noarch
Oct 17 16:58:08 Updated: m17n-contrib-bengali-1.1.7-4.fc10.noarch
Oct 17 16:58:08 Updated: m17n-contrib-telugu-1.1.7-4.fc10.noarch
Oct 17 16:58:09 Updated: m17n-contrib-tamil-1.1.7-4.fc10.noarch
Oct 17 16:58:09 Updated: m17n-db-bengali-1.5.2-3.fc10.noarch
Oct 17 16:58:09 Updated: m17n-contrib-kannada-1.1.7-4.fc10.noarch
Oct 17 16:58:09 Updated: m17n-contrib-assamese-1.1.7-4.fc10.noarch
Oct 17 16:58:10 Updated: m17n-db-kannada-1.5.2-3.fc10.noarch
Oct 17 16:58:10 Updated: m17n-db-assamese-1.5.2-3.fc10.noarch
Oct 17 16:58:11 Updated: m17n-db-oriya-1.5.2-3.fc10.noarch
Oct 17 16:58:11 Updated: m17n-contrib-punjabi-1.1.7-4.fc10.noarch
Oct 17 16:58:11 Updated: m17n-db-hindi-1.5.2-3.fc10.noarch
Oct 17 16:58:11 Updated: m17n-db-gujarati-1.5.2-3.fc10.noarch
Oct 17 16:58:12 Updated: m17n-contrib-gujarati-1.1.7-4.fc10.noarch
Oct 17 16:58:12 Updated: m17n-contrib-oriya-1.1.7-4.fc10.noarch
Oct 17 16:58:12 Updated: m17n-db-tamil-1.5.2-3.fc10.noarch
Oct 17 16:58:12 Updated: m17n-contrib-hindi-1.1.7-4.fc10.noarch
Oct 17 16:58:12 Updated: m17n-db-sinhala-1.5.2-3.fc10.noarch
Oct 17 16:58:13 Updated: m17n-db-telugu-1.5.2-3.fc10.noarch
Oct 17 16:58:13 Updated: m17n-contrib-sinhala-1.1.7-4.fc10.noarch
Oct 17 16:58:13 Updated: m17n-db-malayalam-1.5.2-3.fc10.noarch
Oct 17 16:58:13 Updated: m17n-db-punjabi-1.5.2-3.fc10.noarch
Oct 17 16:58:13 Updated: m17n-contrib-malayalam-1.1.7-4.fc10.noarch
Oct 17 16:58:14 Updated: plymouth-libs-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:14 Updated: setroubleshoot-2.0.12-1.fc10.noarch
Oct 17 16:58:15 Updated: plymouth-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:16 Updated: plymouth-plugin-label-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:16 Updated: plymouth-utils-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:21 Updated: plymouth-plugin-spinfinity-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:22 Updated: mkinitrd-6.0.67-1.fc10.i386
Oct 17 16:58:38 Installed: kernel-PAE-2.6.27-13.fc10.i686
Oct 17 16:58:38 Updated: plymouth-gdm-hooks-0.6.0-0.2008.10.15.1.fc10.i386
Oct 17 16:58:51 Updated: 1:gdm-2.24.0-10.fc10.i386
Oct 17 16:58:56 Updated: 1:gdm-user-switch-applet-2.24.0-10.fc10.i386
Oct 17 17:01:26 Installed: kernel-PAE-2.6.27-13.fc10.i686
Oct 17 17:17:09 Installed: 1:anaconda-yum-plugins-1.0-3.fc10.noarch
Oct 17 17:17:10 Installed: createrepo-0.9.5-5.fc10.noarch
Oct 17 17:17:11 Installed: preupgrade-0.9.8-2.fc10.noarch
Comment 8 Matthias Clasen 2008-10-24 11:05:33 EDT
> The error was 'BadMatch (invalid parameter attributes)'.
>  (Details: serial 1198 error_code 8 request_code 2 minor_code 0)
>  (Note to programmers: normally, X errors are reported asynchronously;
>   that is, you will receive the error a while after causing it.
>   To debug your program, run it with the --sync command line
>   option to change this behavior. You can then get a meaningful
>   backtrace from your debugger if you break on the gdk_x_error() function.)

Can you do as requested here ?

Install debuginfo for nautilus (most easily with debuginfo-install from the yum-utils package), run nautilus under gdb, and break in gdk_x_error. The
stacktrace will tell us what X request causes this error.
Comment 9 npiotrowski 2008-10-24 12:17:58 EDT
Created attachment 321427 [details]
Results of nautilus gdb session
Comment 10 Matthias Clasen 2008-10-24 13:19:47 EDT
I don't think that is the right stacktrace...
Did you start nautilus with --sync ?
Comment 11 npiotrowski 2008-10-24 14:22:38 EDT
Created attachment 321442 [details]
Results of "nautilus --sync" gdb session

Sorry, last time I didn't add --sync option. I'm afraid that even with that option results are not different.
Comment 12 Matthias Clasen 2008-10-24 14:51:31 EDT
Thanks, this is very useful.

Looks like  a problem with the background fading code.
Comment 13 Ray Strode [halfline] 2008-10-24 15:52:25 EDT
This was caused by an uninitalized variable in a function in gnome-desktop.

I'm going to close this bug, but if you still experience it after 

gnome-desktop-2.24.1-2

in tomorrow's rawhide then please reopen.
Comment 14 ltcarneiro 2008-10-27 13:57:58 EDT
I'm having the same problems here and I have updated gnome-desktop to version 2.24.1-2, but the problem changed a bit. 
With the older version, I only could start nautilus with "--no-desktop". Now, if I kill bonobo-activation-server and start nautlus manually it works. It gives some erros like "can't add monitor" but works.
I have dual display configured, without xinerama and this problem can be related to this?
I think this problem is not fixed yet....
Comment 15 Ray Strode [halfline] 2008-10-27 15:07:06 EDT
Leo, just to be sure I'm understanding you, if you boot up and try to log in, nautilus doesn't start for you?  Is it *every* time? or once in a while?

When it does happen, does ~/.xsession-errors mention BadMatch like comment 7 ?
Comment 16 ltcarneiro 2008-10-28 09:13:36 EDT
Yes, when I boot up, and log in nautilus doesn't start up. And this is every time.

If I kill bonobo-activation-server and start nautilus by hand, it works.

If I don't kill bonobo, and try to start nautilus, the error is this:

---
(nautilus:1156): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(nautilus:1156): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (nautilus:1156): WARNING **: Unable to add monitor: Não há suporte
The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1647 error_code 8 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
---

I update my system every day, since I updated to rawhide, and, besides this error, everything appears to work fine.

Sorry but right now I don't have more info because I need to do some work and right now I'm using XFCE4 to have a usable desktop :-)

Thanks
Comment 17 cornel panceac 2008-11-06 06:07:49 EST
the bug is still present on fedora 9

$ rpm -q nautilus
nautilus-2.22.5.1-1.fc9.i386

any hope for the fix to be backported?
Comment 18 Ray Strode [halfline] 2008-11-06 09:29:51 EST
Hi Cornel,

The bug fix that was introduced for this report fixes code that didn't exist in F9.  Your issue must be different.  Can you file a separate bug report?
Comment 19 cornel panceac 2008-11-12 03:57:19 EST
ok

https://bugzilla.redhat.com/show_bug.cgi?id=471179

thnx a lot

Note You need to log in before you can comment on or make changes to this bug.