Bug 460762 - Recent kernels don't boot off USB devices
Recent kernels don't boot off USB devices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-08-31 04:57 EDT by antonio montagnani
Modified: 2008-09-10 16:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 16:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against mkinitrd-6.0.62 (44.98 KB, application/octet-stream)
2008-09-08 08:48 EDT, Michal Hlavinka
no flags Details
upstream's patch for usb booting (2.03 KB, patch)
2008-09-09 04:56 EDT, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description antonio montagnani 2008-08-31 04:57:54 EDT
Description of problem:
When using latest kernels I can't boot off my USB Hard drive

Version-Release number of selected component (if applicable):
latest working kernel is kernel-2.6.27-0.244.rc2.git1.fc10.i686

How reproducible:
just boot off an HD drive

Steps to Reproduce:
1.switch on computer
2.wait
3.
  
Actual results:
I get following messages:
stabilized: stat /proc/bus/usb/devices: No such file or directory
Reading all physical volumes.This may take a while
Volume group "VolGroup00" not found
Unable to access resume device (dev/VolGroup00/LogVol01)

mount: error mounting /dev/root on /sysroot as ext3: No such file or directory
setuproot moving /dev failed:No such file or directory
setuproot error mounting /proc
switchroot: mount failed: /sys No such file or directory

Expected results:
normal boot

Additional info:

some other reporter sees slightly different messages
Comment 1 antonio montagnani 2008-09-04 07:29:56 EDT
kernel-2.6.27-0.186.rc0.git15.fc10.i686 has same problem...

I switch to urgent as in continuous upgrading some user booting off any USB device can experience a system that is not booting any more....
Comment 2 antonio montagnani 2008-09-04 07:32:06 EDT
my previous comment has to be read as kernel-2.6.27-0.297.rc5.git2.fc10.i686
kernel-2.6.27-0.186.rc0.git15.fc10.i686 is running fine....
Comment 3 antonio montagnani 2008-09-05 11:15:05 EDT
kernel-2.6.27-0.305.rc5.git6.fc10.i686 doesn't boot either
Comment 4 antonio montagnani 2008-09-07 09:54:32 EDT
kernel-2.6.27-0.312.rc5.git7.fc10.i686 doesn't boot either
Comment 5 Michal Hlavinka 2008-09-08 03:36:50 EDT
I was looking around this bug, I can't boot from usb too.

Problem is located inside mkinitrd, new kernels don't use ?hci-hcd.ko modules, but mkinitrd uses them for usb boot detection. In all these broken initrd.imgs there is missing line:

mount -t usbfs /proc/bus/usb /proc/bus/usb

if you add this line into your initrd.img/init after this line:
mkblkdevs

it'll be bootable again (I won't write here how to modify initrd.img, you can find it via google)

Problem is that all these modules are not modules anymore, but they are directly in kernel. For now only usb-storage.ko is remaining as a module, but for how long?

Better usb detection in mkinitrd is needed
Comment 6 Michal Hlavinka 2008-09-08 05:22:41 EDT
I've prepared patch to fix this, going to test it now
Comment 7 Michal Hlavinka 2008-09-08 08:48:17 EDT
Created attachment 316076 [details]
patch against mkinitrd-6.0.62
Comment 8 Michal Hlavinka 2008-09-08 09:00:10 EDT
Well... I can see it's already fixed in mkinitrd's git repository since 11 Aug 2008. This will be fixed in new released version.
Comment 9 Michal Hlavinka 2008-09-09 04:56:07 EDT
Created attachment 316160 [details]
upstream's patch for usb booting

this patch is applicable against mkinitrd 6.0.62 in cvs, new version of mkinitrd should be released or mkinitrd-6.0.62 should repackaged with this patch to fix this for F10Beta
Comment 10 antonio montagnani 2008-09-10 15:42:38 EDT
2.6.27-0.317.rc5.git10.fc10.i686 is booting fine.
I suggest that it can be closed...

Note You need to log in before you can comment on or make changes to this bug.