Bug 460768 - WACOM tablets do not work in the graphical installer.
WACOM tablets do not work in the graphical installer.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-31 09:12 EDT by Beech Horn
Modified: 2009-07-14 15:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:50:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WACOM Xorg.conf (2.57 KB, application/octet-stream)
2008-09-03 15:22 EDT, Beech Horn
no flags Details

  None (edit)
Description Beech Horn 2008-08-31 09:12:17 EDT
Description of problem: I use a WACOM tablet as my only pointer input and am, as of yet, unable to use it on any graphical installer for any Linux distribution (apart from those who boot into live cd mode).


Version-Release number of selected component (if applicable): ALL


How reproducible: Every time


Steps to Reproduce:
1. Plug in a WACOM tablet as the only pointer device on a computer.
2. Insert the fedora disc.
3. Run the graphical installer and try to navigate around the interface with the WACOM stylus.
  
Actual results: Nothing happens.


Expected results: The WACOM tablet functions as per normal.


Additional info: It's not so much of a pain using the keyboard, until you have to set up the timezone. Typing Alt+Down to get open the dropdown of countries works, but you can't enter "E" to make selecting Europe/London any easier. I've tried the text mode installer (as any GUI advantage would be lost without a pointer) but cannot find LVM options.
Comment 1 Aristeu Rozanski 2008-09-03 13:15:49 EDT
Beech,
I believe this is caused by the new X.org version that truly supports hotplugging.
I'll check that.
Comment 2 Aristeu Rozanski 2008-09-03 15:17:56 EDT
Forget my last comment, I thought you meant it worked before but didn't on F-9.
I'll check if it's possible to include it.
Comment 3 Beech Horn 2008-09-03 15:22:52 EDT
Created attachment 315675 [details]
WACOM Xorg.conf

Thank you Aristeu,

I am willing to burn ISO's compile changes before Fedora 10.

It's not a Fedora specific problem as mentioned, as I do not know of any Linux installer to date (beyond Live CD's) which allow the WACOM to work.

The RHGB (Red Hat Graphical Boot) does support the WACOM (but as it now uses X I suppose this is a mute point).

The automatic X doesn't support absolute stylus modes, etc and requires manual entries into the Xorg.conf. Please see the uploaded file as an example. To clarify the LinuxWACOM documentation suggests that stylus/eraser input will use absolute positioning by default, however without a device entry into the Xorg.conf file this does not happen.
Comment 4 Aristeu Rozanski 2008-09-03 16:57:12 EDT
Beech,
there're two points:
- your tablet won't work, even detected as a mouse thru /dev/input/mice on
  Fedora installation because the kernel module is not present so the device
  is not usable at all.
- after installed, the wacom kernel module is available and will be somewhat
  usable even without configuration. Not sure about F9, but new X servers (xorg)
  do support hotplugging. If the _xorg_ wacom driver is available, it'll load
  it and make it available automatically.

so, two different problems: one is being usable during the installation and the
second problem is working without manual configuration. the second is being
handled on a separated bug.
Comment 5 Beech Horn 2008-11-24 04:38:22 EST
Please could I have the bug number for the manual configuration issue - as my searching skills seem to be lacking...

Thank you

Aristeu
Comment 6 A. Lok 2008-11-24 13:12:12 EST
I think Aristeu means bug#109750

You could also try the link '(Show Fedora/linuxwacom bugs)' aside the Component description in the 'header' of this bug. Or use http://bugz.fedoraproject.org/linuxwacom to find bugs filed against linuxwacom.
Comment 7 Bug Zapper 2009-06-09 22:35:32 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-07-14 12:50:59 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 A. Lok 2009-07-14 15:23:28 EDT
This 'problem' still manifests itself in the Fedora 11 installer. I think it shouldn't be closed but 'upgraded' to Fedora 11.

To get back to point 1 from comment #4 , why isn't the wacom kernel-module available anyway? Is this intentional?

Note You need to log in before you can comment on or make changes to this bug.