Bug 460798 - [I18N] String disambiguation
[I18N] String disambiguation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 04:54 EDT by Robert-André Mauchin
Modified: 2008-09-04 11:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 11:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert-André Mauchin 2008-09-01 04:54:04 EDT
Hi,

During the translation process of pulseaudio we notice this string in the command line help (/src/utils/pacat.c:490) :

"      --format=SAMPLEFORMAT             The sample type, one of s16le, s16be, u8, float32le,\n"
"                                        float32be, ulaw, alaw (defaults to s16ne)\n"

It is strange that s16ne is the default as it doesn't appear in the previous list. Please, could you confirm that this is correct and not a typo.
Comment 1 Lennart Poettering 2008-09-04 11:27:09 EDT
Actually s16ne is right, since it is just an alias to the native endian s16 type of the local machine. The man page is more elaborate about this.

It might indeed be a bit surprising but I'd like to leave --help much terser than the man page, and hence i'd like to leave it the way it is right now.

Thanks anyway for pointing this out!

Note You need to log in before you can comment on or make changes to this bug.