Bug 460809 - runlevel 3<->5 spurious service starts
runlevel 3<->5 spurious service starts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 07:37 EDT by Need Real Name
Modified: 2008-09-03 03:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 19:58:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-09-01 07:37:24 EDT
Something odd is going on..

# init 5
starting portreserve
starting anacron
starting irqbalance

# init 3
starting portreserve
starting anacron
starting irqbalance

# init 5
starting portreserve
starting anacron
starting irqbalance
Comment 1 Bill Nottingham 2008-09-02 14:34:00 EDT
This is an issue with the scripts in question. Moving to one of the components, please file bugs separately against the others.
Comment 2 Neil Horman 2008-09-02 15:37:12 EDT
are you running this service on a system with either a single cpu, or a cpu with multiple cores that shares the same L2 cache?  If so, this is expected behavior. In those environments irqbalance shuts down automatically (after starting successfully) because it detects that balancing irq's is futile (as there is no way to improve cache affinity with only one cache).  As such in each run level, it detects that it is stopped , and restarts , only to stop again.

Irritating yet, but better than the alternatives (keeping a pid file around and not starting when you want it to, etc).
Comment 3 Need Real Name 2008-09-02 17:15:35 EDT
Yes I probably am (some Atom chip, MSI Wind U100).

Will move to one of the other packages for fixing then. Thanks for the info.
Comment 4 Neil Horman 2008-09-02 19:58:39 EDT
Yeah, thats it.  Sorry, wish I could make it more intuitive, but even if I disable the auto shutdown code, I get questions asking why irqbalance doesn't distribute irqs between cores, or some other useless operation.  IIRC, I've got a documentation update in the irqbalance man page slated for a future release that will call attention to this behavior explicitly.

Note You need to log in before you can comment on or make changes to this bug.