Bug 460854 - Bug in initramfs /init detected
Bug in initramfs /init detected
Status: CLOSED DUPLICATE of bug 465725
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
9
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 23:31 EDT by Bob
Modified: 2009-02-04 09:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 09:15:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error while booting to fedora 9.0 using liveusb 2.7 (884 bytes, text/plain)
2008-09-01 23:31 EDT, Bob
no flags Details

  None (edit)
Description Bob 2008-09-01 23:31:07 EDT
Created attachment 315502 [details]
The error while booting to fedora 9.0 using liveusb 2.7

Description of problem: Bug in initramfs /init detected


Version-Release number of selected component (if applicable): LiveUSB 2.7 Fedora #9.0


How reproducible:Everytime


Steps to Reproduce:
1.Load Fedora-9-x86_64-Live.iso using LiveUSB 2.7 to a USB thumb drive 8gb
2.After you have loaded go to > System>Administration> and select the update systems.
3. During the updates or sometimes after it downloads the system will hang and require a hard reboot.
  
Actual results:
Loading VMLINUX0
Loading initrd0.img.........ready.

Decompressing Linux - Done.
Booting the Kernel

USB 1-1:device descriptor read/63, error - 71
sd 6:0:0:0[sdc] Assuming drive cache write through
sd 6:0:0:0[sdc] Assuming drive cache write through
Buffer I/O error on device dm-0 logical block 0
Buffer I/O error on device dm-0 logical block 1
Buffer I/O error on device dm-0 logical block 2
Buffer I/O error on device dm-0 logical block 3
Buffer I/O error on device dm-0 logical block 0
Buffer I/O error on device dm-0 logical block 1048560
Buffer I/O error on device dm-0 logical block 1048560
Buffer I/O error on device dm-0 logical block 0
Buffer I/O error on device dm-0 logical block 1
Buffer I/O error on device dm-0 logical block 2

Mount: you must specify the filesystem type
Bug in initramfs /init detected
Dropping to a shell. Good Luck!
bash - 3.2#


Expected results:
To be able to load on a thumb drive so I can boot to linux and still have my vista as well loaded. I have loaded ubuntu on a 500gb drive and use the bios to load it and works good. My teacher wants us to use Fedora though. I don't have that drive hooked up while trying this BTW. 

Additional info: The UNIX course I have currently started in College wants us to use Fedora 6.0 I have vista ultimate on my laptop 64bit and heard that fedora 6.0 is not compatible with fedora 6.0 and I asked my teacher if I could use fedora 9 and he said okay. I heard that LiveUSB was good and worked good with LiveUSB 2.7 I also noticed that before I downloaded the updates this time. I had an error saying "no fstab.sys"

So I need some help.  Thank You.
Comment 1 Luke Macken 2008-11-06 22:40:39 EST
Hey Jeremy,

Many people still seem to be hitting liveusb bugs with regard to applying updates.  Have we tracked any of these issues down, or know what is causing them?  I'm aware that we cannot currently apply kernel updates from live media, but shouldn't everything else Just Work?  Thanks.
Comment 2 CAI Qian 2009-02-01 00:11:58 EST
I have seen this on i686 distribution too, and the overlay image looks like totally unrecoverable. Looks like loads of people are affecting by this,

https://fedorahosted.org/liveusb-creator/ticket/28
Comment 3 CAI Qian 2009-02-04 05:11:23 EST
Looks like osmin.img is fine. If I mkfs.ext3 the overlay image, then dmsetup command worked fine when creating DM snapshot for live-rw.
Comment 4 Jeremy Katz 2009-02-04 09:15:40 EST
The problem is that the overlay fills up and that there is then nothing that can really be done.  Fedora 10 adds the 'reset_overlay' option that you can pass on the kernel command line which helps to recover, but ultimately, we need something better than dm-snapshot to use for the overlay

*** This bug has been marked as a duplicate of bug 465725 ***

Note You need to log in before you can comment on or make changes to this bug.